Project

General

Profile

Actions

Bug #1884

closed

The addupdate target on the package installation Technique is broken. We should enable it again when possible

Added by Matthieu CERDA over 12 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
4
Category:
Techniques
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Name check:
Fix check:
Regression:

Description

The addupdate target on the package installation PT is broken. We should enable it again when possible


Related issues 2 (0 open2 closed)

Related to Rudder - User story #4298: Install / upgrade packagesRejected2013-12-30Actions
Has duplicate Rudder - Bug #6957: You can't do install+update in one shot in the install package techniqueRejected2015-07-10Actions
Actions #2

Updated by Jonathan CLARKE over 12 years ago

  • Target version set to 18
Actions #3

Updated by François ARMAND over 12 years ago

  • Target version changed from 18 to 2.4.0~alpha1
Actions #4

Updated by Jonathan CLARKE over 12 years ago

  • Target version changed from 2.4.0~alpha1 to 2.4.0~alpha2
Actions #5

Updated by Jonathan CLARKE over 12 years ago

  • Target version changed from 2.4.0~alpha2 to 2.4.0~alpha3
Actions #6

Updated by Matthieu CERDA over 12 years ago

  • Status changed from New to Discussion

This still seems broken in CFengine, no class gets raised when the package is already installed and up to date.

rudder> Checking if package (nano,*,*) is at the desired state (installed=1,matched=1)
rudder>  -> Package promises to refer to itself as "nano" to the manager
rudder>  -> Package version seems to match criteria
rudder> Checking if latest available version is newer than installed...
rudder> Looking for an installed package older than (nano,*,*)
rudder> Found installed package (nano,2.2.4-1,default)
rudder> Installed package is up to date, not updating

For reference, here is the add flavor output :

rudder> Checking if package (nano,*,*) is at the desired state (installed=1,matched=1)
rudder>  -> Package promises to refer to itself as "nano" to the manager
rudder>  -> Package version seems to match criteria
rudder>  -> Package "nano" already installed, so we never add it again
rudder>  ?> defining promise result class debian_install_kept_nano

Actions #7

Updated by Jonathan CLARKE about 12 years ago

  • Target version changed from 2.4.0~alpha3 to 2.4.0~alpha4
Actions #8

Updated by François ARMAND about 12 years ago

  • Target version changed from 2.4.0~alpha4 to 2.4.0~alpha5
Actions #9

Updated by Jonathan CLARKE about 12 years ago

  • Target version changed from 2.4.0~alpha5 to 2.4.0~alpha6
Actions #10

Updated by Jonathan CLARKE about 12 years ago

  • Target version changed from 2.4.0~alpha6 to 2.4.0~alpha7
Actions #11

Updated by Jonathan CLARKE almost 12 years ago

  • Target version changed from 2.4.0~alpha7 to 2.3.8
Actions #12

Updated by Jonathan CLARKE almost 12 years ago

  • Target version changed from 2.3.8 to 24
Actions #13

Updated by Jonathan CLARKE almost 12 years ago

  • Target version changed from 24 to Ideas (not version specific)
Actions #14

Updated by Nicolas CHARLES over 9 years ago

  • Status changed from Discussion to 8
  • Assignee set to Nicolas CHARLES
  • Target version changed from Ideas (not version specific) to 2.10.8

i hope it's been fixed in CFEngine

Actions #15

Updated by Nicolas CHARLES over 9 years ago

Ok, this is actually like the standart update: we cannot simply latest to have latest version
We have a nice solution on RPM, so i'll be using it on RPM
It has not yet been implemented on DEB however

Actions #16

Updated by Nicolas CHARLES over 9 years ago

hum, i've been a bit optimisstic
addupdate still doesn't work as expected... i get always repaired state, or no reports

trying to tinker with it, forcing target version when available, or considering it as an update all fails

Actions #17

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.8 to 2.10.9
Actions #18

Updated by Jonathan CLARKE over 9 years ago

The link to the old bugtracker has been updated: http://auth.cfengine.com/bugtracker/view.php?id=532

It seems we need to define a specific classes body with return code outcomes for this to work. Could you test again?

Actions #19

Updated by Nicolas CHARLES over 9 years ago

addupdate is more broken than that: it simply does not install if you specify a target version and package was not there, it does not update if it is installed

Actions #20

Updated by Nicolas CHARLES over 9 years ago

but we could "simply" convert the addupdate to "install" and then "update", and aggregate the reports from both

Actions #21

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.9 to 2.10.10
Actions #22

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.10 to 2.10.11
Actions #23

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.11 to 2.10.12
Actions #24

Updated by Benoît PECCATTE about 9 years ago

  • Project changed from 24 to Rudder
  • Category changed from Policy Templates to Techniques
Actions #25

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.12 to 2.10.13
Actions #26

Updated by Benoît PECCATTE about 9 years ago

  • Status changed from 8 to New
Actions #27

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.13 to 2.10.14
Actions #28

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.14 to 2.10.15
Actions #29

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.15 to 2.10.16
Actions #30

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.16 to 2.10.17
Actions #31

Updated by Jonathan CLARKE over 8 years ago

  • Subject changed from The addupdate target on the package installation PT is broken. We should enable it again when possible to The addupdate target on the package installation Technique is broken. We should enable it again when possible
Actions #32

Updated by Jonathan CLARKE over 8 years ago

  • Has duplicate Bug #6957: You can't do install+update in one shot in the install package technique added
Actions #33

Updated by Jonathan CLARKE over 8 years ago

Actions #34

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.17 to 2.10.18
Actions #35

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.18 to 2.10.19
Actions #36

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.19 to 2.10.20
Actions #37

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.20 to 2.11.18
Actions #38

Updated by Jonathan CLARKE over 8 years ago

  • Translation missing: en.field_tag_list set to Quick and important
  • Assignee changed from Nicolas CHARLES to Alexis Mousset

Marking this as "Quick and important" because it is quick to test whether this now works as expected, at least in CFEngine 3.6 or 3.7.

Alexis, can you please do this test, and check the result classes. If it works in any given version, let's enable it there, because this is a key feature to have disabled :(

If you can see a way of fixing it in earlier versions, that would be a huge bonus, too.

Actions #39

Updated by Alexis Mousset over 8 years ago

  • Status changed from New to In progress

Matthieu CERDA wrote:

This still seems broken in CFengine, no class gets raised when the package is already installed and up to date.
[...]

This should be fixed since #6996, testing in 2.11.

Actions #40

Updated by Alexis Mousset over 8 years ago

Seems to work well when adding the mechanism we use for updates to detect new versions.

Tested on Centos 6, Rudder 3.1

Only a little reporting issue:

R: @@packageInstallation@@result_repaired@@32377fd7-02fd-43d0-aab7-28460a91347b@@1117c83d-b78e-4883-b737-7ae90825846e@@7@@RHEL/CentOS/SuSE packages@@nmap@@2016-01-19 12:06:58+00:00##root@#Performed repair action for RPM package nmap to comply with policy: addupdate
R: @@packageInstallation@@result_success@@32377fd7-02fd-43d0-aab7-28460a91347b@@1117c83d-b78e-4883-b737-7ae90825846e@@7@@RHEL/CentOS/SuSE packages@@nmap@@2016-01-19 12:06:58+00:00##root@#No action required for RPM package nmap with policy: addupdate
Actions #41

Updated by Alexis Mousset over 8 years ago

The reporting problems seems to be #7623, which is already fixed!

Actions #42

Updated by Jonathan CLARKE over 8 years ago

Excellent news! Can you confirm it also works well on apt systems?

If so, let's make a simple PR to reenable this ASAP. We may need to check behaviour on Rudder 2.10, because a 2.11 server can still have 2.10 agents.

Actions #43

Updated by Alexis Mousset over 8 years ago

Update without specified version won't work on apt systems, but it is currently the case for simple update too (#6994).

Actions #44

Updated by Alexis Mousset over 8 years ago

I am testing the change on RPM systems on 2.10, 2.11 and 3.1.

Actions #45

Updated by Alexis Mousset over 8 years ago

Finally not as easy as it seemed, we will have to split the cases to use the update mechanism in the technique (and also lose the benefits of addupdate).

Actions #46

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #47

Updated by Alexis Mousset about 8 years ago

  • Status changed from In progress to Discussion
Actions #48

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #49

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #50

Updated by Alexis Mousset almost 8 years ago

Actions #51

Updated by Jonathan CLARKE almost 8 years ago

  • Related to deleted (User story #8230: Package management issues in Rudder/ncf)
Actions #52

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #53

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #54

Updated by Alexis Mousset almost 8 years ago

  • Translation missing: en.field_tag_list deleted (Quick and important)
Actions #55

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #56

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.24 to 308
Actions #57

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 308 to 3.1.14
Actions #58

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #59

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #60

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #61

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #62

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #63

Updated by Alexis Mousset about 7 years ago

  • Status changed from Discussion to Rejected

This is:

  • supported in the new packages Technique
  • possible in rpmPackageInstallation using install+update

addupdate is broken and cannot be enabled, closing.

Actions

Also available in: Atom PDF