Project

General

Profile

Actions

Bug #19092

closed

Rudderc doesn't compile

Added by Alexis Mousset about 3 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
N/A
Category:
rudderc
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:

Description

    Checking rudderc v0.0.0-dev (/home/amousset/projects/rudder/rudder-lang)
error: expected identifier, found `<<`
   --> src/technique/from_ir.rs:260:1
    |
256 |             vec![MethodCall {
    |                  ---------- while parsing this struct
...
260 | <<<<<<< HEAD
    | ^^ expected identifier

error: expected identifier, found `==`
   --> src/technique/from_ir.rs:268:1
    |
256 |             vec![MethodCall {
    |                  ---------- while parsing this struct
...
268 | =======
    | ^^ expected identifier

error: expected identifier, found `"component"`
   --> src/technique/from_ir.rs:269:61
    |
256 |             vec![MethodCall {
    |                  ---------- while parsing this struct
...
269 |                 component: extract_meta_string(&s.metadata, "component"),
    |                                                             ^^^^^^^^^^^ expected identifier

error: expected identifier, found `>>`
   --> src/technique/from_ir.rs:271:1
    |
256 |             vec![MethodCall {
    |                  ---------- while parsing this struct
...
271 | >>>>>>> 52c206b0b (fixup! fixup! fixup! fixup! fixup! fixes #18953: Port technique editor in elm)
    | ^^ expected identifier

error[E0425]: cannot find function `extract_meta_string` in this scope
   --> src/technique/from_ir.rs:270:21
    |
270 |                 id: extract_meta_string(&s.metadata, "id"),
    |                     ^^^^^^^^^^^^^^^^^^^ not found in this scope

error[E0425]: cannot find function `extract_meta_string` in this scope
   --> src/technique/from_ir.rs:314:21
    |
314 |                 id: extract_meta_string(&s.metadata, "id"),
    |                     ^^^^^^^^^^^^^^^^^^^ not found in this scope

error[E0063]: missing field `component` in initializer of `technique::MethodCall`
   --> src/technique/from_ir.rs:256:18
    |
256 |             vec![MethodCall {
    |                  ^^^^^^^^^^ missing `component`

error: aborting due to 7 previous errors

Some errors have detailed explanations: E0063, E0425.
For more information about an error, try `rustc --explain E0063`.
error: could not compile `rudderc`

To learn more, run the command again with --verbose.

Actions #1

Updated by Alexis Mousset about 3 years ago

  • Status changed from New to In progress
  • Assignee set to Alexis Mousset
Actions #2

Updated by Alexis Mousset about 3 years ago

  • Status changed from In progress to Rejected
Actions

Also available in: Atom PDF