Project

General

Profile

Actions

Bug #19526

closed

Bug #19868: Rudder package should accept plugins with same minor version, not just patch version

Change the plugin version check to 7.0 for upgrade

Added by François ARMAND almost 3 years ago. Updated almost 3 years ago.

Status:
Released
Priority:
N/A
Category:
System integration
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:

Description

In rudder upgrade, we check if plugins are compatible with current version with a hardcoded value to 6.2. It needs to be changed to 7.0.

See #19517 PR to see where the code need to be changed (https://github.com/Normation/rudder-packages/pull/2501/files)


Related issues 1 (0 open1 closed)

Related to Rudder - Bug #19517: when upgrading rudder, plugins are upgraded, but are disabledReleasedAlexis MoussetActions
Actions #1

Updated by François ARMAND almost 3 years ago

  • Related to Bug #19517: when upgrading rudder, plugins are upgraded, but are disabled added
Actions #2

Updated by Vincent MEMBRÉ almost 3 years ago

  • Status changed from New to In progress
  • Assignee set to Vincent MEMBRÉ
Actions #3

Updated by Vincent MEMBRÉ almost 3 years ago

  • Assignee changed from Vincent MEMBRÉ to François ARMAND
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/2526
Actions #4

Updated by Vincent MEMBRÉ almost 3 years ago

  • Parent task set to #19868

Since changes in #19868, we do not need to specify the version anymore, the version was ignored and was taken from a file created by the package

Actions #5

Updated by Vincent MEMBRÉ almost 3 years ago

  • Status changed from In progress to Pending release
Actions #6

Updated by Vincent MEMBRÉ almost 3 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 7.0.0~beta1 which was released today.

Actions

Also available in: Atom PDF