Project

General

Profile

Actions

Bug #19930

closed

We were able to save a technique without a name which caused chaos

Added by François ARMAND almost 3 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
N/A
Assignee:
-
Category:
Web - Technique editor
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Getting started - demo | first install | Technique editor and level 1 Techniques
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:
No

Description

Not sure how, but we were able to save a technique without giving it a name in the technique editor. After that, techniques files were not created in the correct place in the file system.

This looks related to #16135 (6.0) and #19865 (7.0).


Related issues 3 (1 open2 closed)

Related to Rudder - Bug #16135: We can save a technique with empty name when we add a resourceReleasedRaphael GAUTHIERActions
Related to Rudder - Bug #19865: Technique editor allows empty technique nameReleasedVincent MEMBRÉActions
Related to Rudder - Bug #20142: Invalid metadata (section with empty name) generated by the technique editorNewActions
Actions #1

Updated by François ARMAND almost 3 years ago

  • Related to Bug #16135: We can save a technique with empty name when we add a resource added
Actions #2

Updated by François ARMAND almost 3 years ago

  • Related to Bug #19865: Technique editor allows empty technique name added
Actions #3

Updated by Nicolas CHARLES almost 3 years ago

I reproduced by:
  1. creating a technique, and not setting a name
  2. adding a resource
  3. adding a generic method
  4. clicking on "Clone" - it prompts for a name for the new technique

and then the technique is created in /var/rudder/configuration-repository/techniques/ncf_techniques/1.0/

Interrestingly, the cloned technique is empty

Technique shows up in the technique list, with an empty name

Others methods may apply

Actions #4

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.11 to 6.2.12
  • Priority changed from 70 to 68
Actions #5

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.2.12 to 6.2.13
  • Priority changed from 68 to 67
Actions #6

Updated by François ARMAND over 2 years ago

  • Related to Bug #20142: Invalid metadata (section with empty name) generated by the technique editor added
Actions #7

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.2.13 to 6.2.14
  • Priority changed from 67 to 63
Actions #8

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.2.14 to 6.2.15
  • Priority changed from 63 to 61
Actions #9

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.2.15 to 6.2.16
  • Priority changed from 61 to 60
Actions #10

Updated by Alexis Mousset almost 2 years ago

  • Target version changed from 6.2.16 to 6.2.17
  • Priority changed from 60 to 59
Actions #11

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.2.17 to 997
  • Priority changed from 59 to 0
Actions #12

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 997 to 6.2.18
Actions #13

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.2.18 to 6.2.19
Actions #14

Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 6.2.19 to 6.2.20
Actions #15

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 6.2.20 to old 6.2 issues to relocate
Actions #16

Updated by François ARMAND about 1 year ago

  • Status changed from New to Resolved
  • Regression set to No

The given process is not working anymore in 7.2 since we have real draft.

I'm closing that one but if we find new creative way to save a technique without a name, we will need to plug them too (the backend refuse now, but still).

Actions

Also available in: Atom PDF