Project

General

Profile

Actions

Bug #20031

closed

error at upgrade of rudder to 7.0

Added by Nicolas CHARLES 8 months ago. Updated 6 months ago.

Status:
Released
Priority:
N/A
Category:
Packaging
Target version:
Severity:
User visibility:
Effort required:
Priority:
0

Description

                                          
Fetched 174 MB in 18s (9844 kB/s)                                                                                                                                                              
apt-listchanges: Can't set locale; make sure $LC_* and $LANG are correct!
Reading changelogs... Done
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_TIME = "fr_FR.UTF-8",
    LC_MONETARY = "fr_FR.UTF-8",
    LC_MEASUREMENT = "fr_FR.UTF-8",
    LC_NUMERIC = "fr_FR.UTF-8",
    LC_PAPER = "fr_FR.UTF-8",
    LANG = "en_US.UTF-8" 
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
locale: Cannot set LC_ALL to default locale: No such file or directory
Preconfiguring packages ...
(Reading database ... 70559 files and directories currently installed.)
Preparing to unpack .../0-rudder-reports_7.0.0~beta2~git202110010902-debian10_all.deb ...
Unpacking rudder-reports (7.0.0~beta2~git202110010902-debian10) over (7.0.0~beta2~git202109291354-debian10) ...
Preparing to unpack .../1-rudder-api-client_7.0.0~beta2~git202110010902-debian10_amd64.deb ...
Unpacking rudder-api-client (7.0.0~beta2~git202110010902-debian10) over (7.0.0~beta2~git202109291354-debian10) ...
Preparing to unpack .../2-rudder-webapp_7.0.0~beta2~git202110010902-debian10_amd64.deb ...
********************************************************************************
INFO: dpkg may ask you if you want to replace rudder-web.properties or          
INFO: slapd.conf with the maintainer version.                                   
INFO:                                                                           
INFO: If you accept, please keep in mind that you will lose any manual          
INFO: modifications in this file, like batchs configuration, or LDAP            
INFO: authentication. It will also reset passwords to default values and break  
INFO: upgrade scripts.                                                          
INFO:                                                                           
INFO: We strongly advise you to respond NO to this question                     
INFO: ('keep your currently-installed version'). Rudder's upgrade script will   
INFO: take care of upgrading these file automatically.                          
INFO:                                                                           
********************************************************************************
Unpacking rudder-webapp (7.0.0~beta2~git202110010902-debian10) over (7.0.0~beta2~git202109291354-debian10) ...
Preparing to unpack .../3-rudder-agent_7.0.0~beta2~git202110010902-debian10_amd64.deb ...
INFO: A backup copy of Rudder agent credentials and id has been done in /var/backups/rudder
Unpacking rudder-agent (7.0.0~beta2~git202110010902-debian10) over (7.0.0~beta2~git202109291354-debian10) ...
Preparing to unpack .../4-rudder-server-relay_7.0.0~beta2~git202110010902-debian10_amd64.deb ...
Unpacking rudder-server-relay (7.0.0~beta2~git202110010902-debian10) over (7.0.0~beta2~git202109291354-debian10) ...
Preparing to unpack .../5-rudder-server-root_7.0.0~beta2~git202110010902-debian10_all.deb ...
Unpacking rudder-server-root (7.0.0~beta2~git202110010902-debian10) over (7.0.0~beta2~git202109291354-debian10) ...
Setting up rudder-reports (7.0.0~beta2~git202110010902-debian10) ...
Setting up rudder-agent (7.0.0~beta2~git202110010902-debian10) ...
locale: Cannot set LC_ALL to default locale: No such file or directory
dpkg: error processing package rudder-agent (--configure):
 installed rudder-agent package post-installation script subprocess returned error exit status 1
Setting up rudder-api-client (7.0.0~beta2~git202110010902-debian10) ...
dpkg: dependency problems prevent configuration of rudder-server-root:
 rudder-server-root depends on rudder-agent (>> 7.0.0~beta2~git000000000000); however:
  Package rudder-agent is not configured yet.
  Version of rudder-agent on system, provided by rudder-agent:amd64, is <none>.
 rudder-server-root depends on rudder-agent (<< 7.0.0~beta2~git999999999999); however:
  Package rudder-agent is not configured yet.
  Version of rudder-agent on system, provided by rudder-agent:amd64, is <none>.

dpkg: error processing package rudder-server-root (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rudder-server-relay:
 rudder-server-relay depends on rudder-agent (>> 7.0.0~beta2~git000000000000); however:
  Package rudder-agent is not configured yet.
  Version of rudder-agent on system, provided by rudder-agent:amd64, is <none>.
 rudder-server-relay depends on rudder-agent (<< 7.0.0~beta2~git999999999999); however:
  Package rudder-agent is not configured yet.
  Version of rudder-agent on system, provided by rudder-agent:amd64, is <none>.

dpkg: error processing package rudder-server-relay (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rudder-webapp:
 rudder-webapp depends on rudder-server-relay (>> 7.0.0~beta2~git000000000000); however:
  Package rudder-server-relay is not configured yet.
 rudder-webapp depends on rudder-server-relay (<< 7.0.0~beta2~git999999999999); however:
  Package rudder-server-relay is not configured yet.

dpkg: error processing package rudder-webapp (--configure):
 dependency problems - leaving unconfigured
Processing triggers for rsyslog (8.1901.0-1) ...
Processing triggers for libc-bin (2.28-10) ...
Errors were encountered while processing:
 rudder-agent
 rudder-server-root
 rudder-server-relay
 rudder-webapp
E: Sub-process /usr/bin/dpkg returned an error code (1)

/var/log/rudder/install/rudder-agent-20211001095041.log contains

Fri Oct  1 09:50:41 CEST 2021 - Starting rudder-agent post installation script
rudder-cf-serverd: enabled
rudder-cf-execd: enabled
ok: stop service rudder-agent succeeded
INFO: Scheduling an inventory during next run...
rudder agent check is already running


Related issues

Related to Rudder - Bug #20196: Error when upgrading from 6.2 to 7.0 on sles15RejectedActions
Actions #1

Updated by Nicolas CHARLES 8 months ago

it's because rudder agent check is running, so it exit 1, and fails

Actions #2

Updated by Vincent MEMBRÉ 7 months ago

  • Target version changed from 7.0.0~beta2 to 7.0.0~beta3
Actions #3

Updated by Nicolas CHARLES 7 months ago

  • Related to Bug #20196: Error when upgrading from 6.2 to 7.0 on sles15 added
Actions #4

Updated by Nicolas CHARLES 7 months ago

  • Subject changed from error at upgrade of rudder from 7.0 to 7.0 to error at upgrade of rudder to 7.0
Actions #5

Updated by Nicolas CHARLES 7 months ago

  • Status changed from New to In progress
  • Assignee set to Nicolas CHARLES
Actions #6

Updated by Nicolas CHARLES 7 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Nicolas CHARLES to Alexis MOUSSET
  • Pull Request set to https://github.com/Normation/rudder-agent/pull/353
Actions #7

Updated by Nicolas CHARLES 7 months ago

  • Pull Request changed from https://github.com/Normation/rudder-agent/pull/353 to https://github.com/Normation/rudder-agent/pull/354
Actions #8

Updated by Nicolas CHARLES 7 months ago

  • Status changed from Pending technical review to Pending release
Actions #9

Updated by Vincent MEMBRÉ 6 months ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 7.0.0~beta3 which was released today.

Actions

Also available in: Atom PDF