Project

General

Profile

Actions

Bug #20044

closed

Auth backends does not compile in 7.0.0~beta2

Added by Vincent MEMBRÉ over 2 years ago. Updated 8 months ago.

Status:
Released
Priority:
N/A
Assignee:
-
Target version:
-
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:

Description

Auth backends is not compiling anymore

00:01:55.909  [ERROR] /home/jenkins/workspace/7.0-plugins/check-plugins-with-next-rudder/rudder-plugins/auth-backends/src/main/scala/com/normation/plugins/authbackends/api/AuthBackendsApi.scala:45: error: object ApiVersion is not a member of package com.normation.rudder.rest
00:01:55.909  [ERROR] import com.normation.rudder.rest.ApiVersion
00:01:55.909  [ERROR]        ^
00:01:55.909  [ERROR] /home/jenkins/workspace/7.0-plugins/check-plugins-with-next-rudder/rudder-plugins/auth-backends/src/main/scala/com/normation/plugins/authbackends/api/AuthBackendsApi.scala:111: error: not found: type ApiVersion
00:01:55.909  [ERROR]     def process0(version: ApiVersion, path: ApiPath, req: Req, params: DefaultParams, authzToken: AuthzToken): LiftResponse = {
00:01:55.909  [ERROR]                           ^
00:01:55.909  [ERROR] 2 errors

Related issues 1 (0 open1 closed)

Related to Rudder - Bug #19869: Persist revisions of node inventories in fact-repositoryReleasedVincent MEMBRÉActions
Actions

Also available in: Atom PDF