Project

General

Profile

Actions

Bug #20734

closed

Duplicate classes RudderUserDetails

Added by François ARMAND 10 months ago. Updated 8 months ago.

Status:
Released
Priority:
N/A
Category:
Architecture - Internal libs
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

During a refactoring, we duplicated (in place of moving) RudderUserDetails and CurrentUser.
This can lead to really suprising behaviour, and it's a suprise nothing broke.

Old RudderUserDetails does not seem to be used in plugins.
Unfortunatly, CurrentUser (the incorrect one) is used in ChangeValidation, so we will need to keep a stub for compat if we want to do it in 6.2.

For that, I propose to do the change in 7.0 only and only backport if an user-visible problem is discovered because of that.


Related issues 1 (1 open0 closed)

Related to Change validation - Bug #20735: Counterpart of 20734: update import for RudderUserDetailsPending releaseVincent MEMBRÉActions
Actions #1

Updated by François ARMAND 10 months ago

  • Status changed from New to In progress
Actions #2

Updated by François ARMAND 10 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from François ARMAND to Vincent MEMBRÉ
  • Pull Request set to https://github.com/Normation/rudder/pull/4162
Actions #3

Updated by Vincent MEMBRÉ 10 months ago

  • Target version changed from 7.0.1 to 7.0.2
Actions #4

Updated by François ARMAND 10 months ago

  • Target version changed from 7.0.2 to 6.2.13

We decided to target 6.2 branch for that ticket that is needed for oauth plugin

Actions #5

Updated by François ARMAND 10 months ago

  • Related to Bug #20735: Counterpart of 20734: update import for RudderUserDetails added
Actions #6

Updated by François ARMAND 9 months ago

  • Status changed from Pending technical review to Pending release
Actions #8

Updated by Vincent MEMBRÉ 8 months ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 6.2.13, 7.0.2 and 7.1.0~rc1 which were released today.

Actions

Also available in: Atom PDF