Project

General

Profile

Actions

Bug #21005

open

Upgrade notes documentation is not clear enough

Added by Félix DALLIDET 4 months ago. Updated 23 days ago.

Status:
New
Priority:
N/A
Assignee:
-
Category:
-
Target version:
Severity:
UX impact:
User visibility:
First impressions of Rudder
Effort required:
Very Small
Priority:
0
Regression:

Description

The upgrade notes documentation to upgrade from 6.1/6.2 to 7.0 is confusing.
It starts with https://docs.rudder.io/reference/7.0/installation/upgrade/notes.html#_upgrade_from_rudder_6_1_or_6_2_to_7_0:

It is advised to upgrade the root server before upgrading the relays and the nodes, but 7.0 nodes are also compatible with older server. Two cases are unsupported:

But when you upgrade the server first, you expose yourself to trouble if you are using a custom certificate since the API and node communication now used the same certificate by default.
And here https://docs.rudder.io/reference/7.0/installation/upgrade/notes.html#_agent_side_server_certificate_verification we can read:


Before upgrade:

    Upgrade agents to 7.0 before the server. This will allow the agent to


The sentence is unfinished but conflicts with the previous statement which recommends to upgrade the root server before the nodes.
If the nodes must be updated first when you are using a custom certificate, I think it should be stated at the top of the documentation, with its limitations (relay upgrade).

But if the root server must always be upgraded first for safety reasons, we should clearly state it and avoid any mention of the other order except in a last resort section.

Actions #1

Updated by Vincent MEMBRÉ 3 months ago

  • Target version changed from 7.0.3 to 7.0.4
Actions #2

Updated by Vincent MEMBRÉ about 2 months ago

  • Target version changed from 7.0.4 to 7.0.5
Actions #3

Updated by Vincent MEMBRÉ 23 days ago

  • Target version changed from 7.0.5 to 7.0.6
Actions

Also available in: Atom PDF