Project

General

Profile

Actions

Bug #23615

closed

The value edited for overridden properties in node is not the node value

Added by François ARMAND 8 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
N/A
Category:
Web - Nodes & inventories
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:
No

Description

When a node has a property that is inherited from a parent group, and that property is also defined in the node, then when on the node you try to edit the property, you see the overridden property, not the node one (for ex when editing a json, you see the merged json, not just the part added in the node).

This is a regression compared to what happens in 7.3.


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #23553: Override process of properties is very misleading at node levelReleasedVincent MEMBRÉActions
Actions #1

Updated by Vincent MEMBRÉ 8 months ago

  • Target version changed from 8.0.1 to 8.0.2
Actions #2

Updated by Vincent MEMBRÉ 7 months ago

  • Target version changed from 8.0.2 to 8.0.3
Actions #3

Updated by Vincent MEMBRÉ 7 months ago

  • Target version changed from 8.0.3 to 8.0.4
Actions #4

Updated by Raphael GAUTHIER 7 months ago

  • Status changed from New to In progress
  • Assignee set to Raphael GAUTHIER
Actions #5

Updated by Raphael GAUTHIER 7 months ago

I can't reproduce anymore, this bug has normally been fixed in #23553

Actions #6

Updated by Raphael GAUTHIER 7 months ago

  • Status changed from In progress to Resolved
Actions #7

Updated by Raphael GAUTHIER 7 months ago

  • Is duplicate of Bug #23553: Override process of properties is very misleading at node level added
Actions

Also available in: Atom PDF