Project

General

Profile

Actions

Bug #2411

closed

CFEngine doesn't expireafter when installing a package

Added by Nicolas CHARLES about 12 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
4
Assignee:
-
Category:
Web - Config management
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Infrequent - complex configurations | third party integrations
Effort required:
Priority:
0
Name check:
Fix check:
Regression:

Description

Sometimes, we edit a configuration file before installing a package, which leads to questions asked by the package-manager, packages which remains without answer for it's tty who should answer, and it stall, and is SIGINTed after quite a long time, and thus the execution is incomplete.

One way to circumvent would be to expireafter the promise, however, it does not seems to work with the packages promises time (ref https://cfengine.com/bugtracker/view.php?id=1012 )


Related issues 1 (0 open1 closed)

Related to Rudder - Bug #2478: aptitude seems to ask questions when run via cf-agent, even with settings for "noninteractive" executionReleasedJonathan CLARKE2012-04-27Actions
Actions #1

Updated by Jonathan CLARKE about 12 years ago

  • Priority changed from N/A to 4
  • Target version changed from 2.3.7 to 2.3.8

This is a bit of a corner case, and while it's annoying, it's not a reason to block the upcoming release, moving to 2.3.8.

Actions #2

Updated by Jonathan CLARKE almost 12 years ago

  • Target version changed from 2.3.8 to 2.3.9
Actions #3

Updated by Nicolas CHARLES almost 12 years ago

The statement from CFEngine devs is that the expireafter is triggered by next CFEngine execution; that's why it wasn't detected with my tests

So we should probably give the expireafter a try

Actions #4

Updated by Nicolas PERRON over 11 years ago

  • Target version changed from 2.3.9 to 2.3.10
Actions #5

Updated by Matthieu CERDA over 11 years ago

  • Target version changed from 2.3.10 to 2.3.11
Actions #6

Updated by Matthieu CERDA about 11 years ago

  • Target version changed from 2.3.11 to 2.3.12
Actions #7

Updated by Matthieu CERDA about 11 years ago

  • Target version changed from 2.3.12 to 2.3.13
Actions #8

Updated by Nicolas PERRON almost 11 years ago

  • Target version changed from 2.3.13 to 84
Actions #9

Updated by Nicolas PERRON almost 11 years ago

  • Target version changed from 84 to 2.4.7
Actions #10

Updated by Nicolas PERRON almost 11 years ago

  • Target version changed from 2.4.7 to 2.4.8
Actions #11

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.8 to 2.4.9
Actions #12

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.9 to 2.4.10
Actions #13

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.10 to 2.4.11
Actions #14

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.11 to 2.4.12
Actions #15

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.12 to 2.4.13
Actions #16

Updated by Vincent MEMBRÉ over 10 years ago

  • Target version changed from 2.4.13 to 2.6.11

Since version 2.4 is not maintained anymore, retageting this issue to 2.6

Actions #17

Updated by Vincent MEMBRÉ about 10 years ago

  • Target version changed from 2.6.11 to 2.6.12
Actions #18

Updated by Vincent MEMBRÉ about 10 years ago

  • Target version changed from 2.6.12 to 2.6.13
Actions #19

Updated by Vincent MEMBRÉ almost 10 years ago

  • Target version changed from 2.6.13 to 2.6.14
Actions #20

Updated by Jonathan CLARKE almost 10 years ago

  • Target version changed from 2.6.14 to 2.6.16
Actions #21

Updated by Jonathan CLARKE almost 10 years ago

  • Target version changed from 2.6.16 to 2.6.17
Actions #22

Updated by Nicolas PERRON almost 10 years ago

  • Target version changed from 2.6.17 to 2.6.18
Actions #23

Updated by Matthieu CERDA over 9 years ago

  • Target version changed from 2.6.18 to 2.6.19
Actions #24

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.6.19 to 2.6.20
Actions #25

Updated by François ARMAND over 9 years ago

  • Target version changed from 2.6.20 to 2.10.10

Nicolas, what is status of that one ? Still relevant ?

Actions #26

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.10 to 2.10.11
Actions #27

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.11 to 2.10.12
Actions #28

Updated by Benoît PECCATTE about 9 years ago

  • Category changed from 14 to Web - Config management
Actions #29

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.12 to 2.10.13
Actions #30

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.13 to 2.10.14
Actions #31

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.14 to 2.10.15
Actions #32

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.15 to 2.10.16
Actions #33

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.16 to 2.10.17
Actions #34

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.17 to 2.10.18
Actions #35

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.18 to 2.10.19
Actions #36

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.19 to 2.10.20
Actions #37

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.20 to 2.11.18
Actions #38

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #39

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #40

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #41

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #42

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #43

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #44

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.24 to 308
Actions #45

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 308 to 3.1.14
Actions #46

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #47

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #48

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #49

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #50

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #51

Updated by François ARMAND about 7 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Infrequent - complex configurations | third party integrations
Actions #52

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
  • Priority set to 0
Actions #53

Updated by Jonathan CLARKE about 7 years ago

  • Assignee deleted (Nicolas CHARLES)
Actions #54

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.20 to 3.1.21
Actions #55

Updated by Jonathan CLARKE about 7 years ago

  • Status changed from New to Rejected

Since #2478 was fixed, this no longer actually has any impact in Rudder. It may be of concern to plain CFEngine users, but not Rudder users. As a result, rejecting this.

Actions

Also available in: Atom PDF