Project

General

Profile

Actions

Bug #24132

closed

Display a custom, no rights dashboard when a user hasn't any rights

Added by François ARMAND 2 months ago. Updated about 2 months ago.

Status:
Rejected
Priority:
N/A
Category:
Web - UI & UX
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:
No

Description

We would like to have a custom dashboard when an user successfully log but doesn't have any permission (no role at all).
It would be less strange than having an empty dashboard.


Files

clipboard-202402021103-nya9h.png (54.4 KB) clipboard-202402021103-nya9h.png François ARMAND, 2024-02-02 11:03

Related issues 1 (0 open1 closed)

Related to Authentication backends - Architecture #24189: No API right with aliased rolesReleasedFrançois ARMANDActions
Actions #1

Updated by François ARMAND 2 months ago

It's likely a bug with what kind of roles lead to it, because we already have a dedicated page, but we don't have for ex with empty OIDC provided roles.

Actions #2

Updated by Clark ANDRIANASOLO about 2 months ago

Actions #3

Updated by Clark ANDRIANASOLO about 2 months ago

  • Status changed from New to Rejected
  • Assignee set to Clark ANDRIANASOLO

It happens with the OIDC authentification which had an issue mapping user authorizations : #24189.

I tested it even when OIDC returns a user with no rights, we now have the same dashboard as in the screenshot.

Actions

Also available in: Atom PDF