Project

General

Profile

Bug #2658

Technique 'User Management': Modifications on /etc/passwd /etc/shadow or /etc/group can result in errors

Added by Nicolas PERRON almost 8 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
3
Category:
Techniques
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:

Description

The promise only check the existence of user in /etc/passwd, so if the associated line in the others files are deleted, no action will be done.
If the user is deleted from /etc/passwd and not in the /etc/group the user will not be able to be created.


Related issues

Related to Rudder - Bug #2584: Technique "User Management": Does not work if group already existRejectedBenoît PECCATTEActions
#1

Updated by Jonathan CLARKE over 7 years ago

  • Assignee deleted (Nicolas PERRON)
#2

Updated by Nicolas PERRON over 7 years ago

  • Target version changed from 2.3.9 to 2.3.10
#3

Updated by Matthieu CERDA over 7 years ago

  • Target version changed from 2.3.10 to 2.3.11
#4

Updated by Jonathan CLARKE over 7 years ago

  • Project changed from Rudder to Techniques
  • Category deleted (Techniques)
#5

Updated by Matthieu CERDA about 7 years ago

  • Target version changed from 2.3.11 to 2.3.12
#6

Updated by Matthieu CERDA about 7 years ago

  • Target version changed from 2.3.12 to 2.3.13
#7

Updated by Nicolas PERRON almost 7 years ago

  • Target version changed from 2.3.13 to 84
#8

Updated by Nicolas PERRON almost 7 years ago

  • Target version changed from 84 to 2.4.7
#9

Updated by Nicolas PERRON almost 7 years ago

  • Target version changed from 2.4.7 to 2.4.8
#10

Updated by Nicolas PERRON almost 7 years ago

  • Target version changed from 2.4.8 to 2.4.9
#11

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.4.9 to 2.4.10
#12

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.4.10 to 2.4.11
#13

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.4.11 to 2.4.12
#14

Updated by Nicolas PERRON over 6 years ago

  • Subject changed from (ex PT/ Technique) User Management: Modifications on /etc/passwd /etc/shadow or /etc/group can result in errors to Technique 'User Management': Modifications on /etc/passwd /etc/shadow or /etc/group can result in errors
#15

Updated by Nicolas PERRON over 6 years ago

  • Status changed from New to Discussion
  • Assignee set to Jonathan CLARKE

It seems important. Don't you agree Jon ?

#16

Updated by Jonathan CLARKE over 6 years ago

  • Assignee deleted (Jonathan CLARKE)
  • Priority changed from 1 to 3

Nicolas PERRON wrote:

It seems important. Don't you agree Jon ?

Right, but not release critical.

There is at least one open pull request against this Technique, like https://github.com/Normation/rudder-techniques/pull/166/files. It should be investigated first, the changes there may affect this bug.

#17

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.4.12 to 2.4.13
#18

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.4.13 to 2.6.11

Since version 2.4 is not maintained anymore, retageting this issue to 2.6

#19

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.6.11 to 2.6.12
#20

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.6.12 to 2.6.13
#21

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 2.6.13 to 2.6.14
#22

Updated by Jonathan CLARKE almost 6 years ago

  • Target version changed from 2.6.14 to 2.6.16
#23

Updated by Jonathan CLARKE almost 6 years ago

  • Target version changed from 2.6.16 to 2.6.17
#24

Updated by Nicolas PERRON almost 6 years ago

  • Target version changed from 2.6.17 to 2.6.18
#25

Updated by Matthieu CERDA over 5 years ago

  • Target version changed from 2.6.18 to 2.6.19
#26

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.6.19 to 2.6.20
#27

Updated by François ARMAND over 5 years ago

  • Status changed from Discussion to New
  • Assignee set to Benoît PECCATTE
  • Target version changed from 2.6.20 to 2.10.10

Benoit, could you check that the bug is still present in 2.10 ?

#28

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.10.10 to 2.10.11
#29

Updated by Benoît PECCATTE over 5 years ago

  • Status changed from New to Discussion

I don't understand at all what this bug is about.

Technique 'User Management': Modifications on /etc/passwd /etc/shadow or /etc/group can result in errors

This is about 'User Management' technique, there are error when it touches etc files

The promise only check the existence of user in /etc/passwd

This is a description of how it works

so if the associated line in the others files are deleted

When could it be deleted ?

no action will be done.

This is a description of how it works

If the user is deleted from /etc/passwd and not in the /etc/group the user will not be able to be created.

If it is deleted why would it be created ?
If the user is deleted only from etc/password and not from etc/group, this is a human made mistake.
If this is a problem, then it is a duplicate of #2584

#30

Updated by Benoît PECCATTE over 5 years ago

  • Assignee changed from Benoît PECCATTE to Nicolas CHARLES

Hey Nicolas, do you think we should mark this as a duplicate of #2584 ?

#31

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.11 to 2.10.12
#32

Updated by Benoît PECCATTE about 5 years ago

  • Project changed from Techniques to Rudder
  • Category set to Techniques
#33

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.12 to 2.10.13
#34

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.13 to 2.10.14
#35

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.14 to 2.10.15
#36

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.10.15 to 2.10.16
#37

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.10.16 to 2.10.17
#38

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.17 to 2.10.18
#39

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.18 to 2.10.19
#40

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.19 to 2.10.20
#41

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.20 to 2.11.18
#42

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.18 to 2.11.19
#43

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.19 to 2.11.20
#44

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.11.20 to 2.11.21
#45

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.11.21 to 2.11.22
#46

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.11.22 to 2.11.23
#47

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.11.23 to 2.11.24
#48

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.11.24 to 308
#49

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 308 to 3.1.14
#50

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.14 to 3.1.15
#51

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.15 to 3.1.16
#52

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.16 to 3.1.17
#53

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.17 to 3.1.18
#54

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.18 to 3.1.19
#55

Updated by François ARMAND about 3 years ago

  • Status changed from Discussion to Rejected

closing as duplicate, as the problem seems to be what is described in #2584

Also available in: Atom PDF