Project

General

Profile

Actions

Bug #2736

closed

We can't apply Directives from different versions of the same Technique on a node

Added by Matthieu CERDA almost 12 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
1
Assignee:
-
Category:
Web - Config management
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Very large
Priority:
6
Name check:
Fix check:
Regression:

Description

If we have two Directive built from the same Technique, but from different versions of that Technique, then trying to apply them to the same Node (in the same Rule or in different Rules) leads to a generation error.

This is due to a long known technical limitation of Rudder: Rudder merge all Directive from a same Technique into only ONE set of policy files, with one set of parameters (where all the parameters of the different techniques are merged). Of course, this can't be working when the parameter or the files are not the same, which is generally the case for different versions.

This is quite annoying and extremelly confusing for user, and make Technique version migration a nightmare (see #4293)


Related issues 5 (0 open5 closed)

Related to Rudder - User story #4293: Migrating from a Technique version to another one in a Directive is long and painfulRejectedActions
Related to Rudder - Architecture #10625: Don't merge directive from same technique on generationReleasedVincent MEMBRÉActions
Related to Rudder - Bug #10580: Cannot mix audit/enforce mode on directives based on the same techniqueRejectedActions
Has duplicate Rudder - Bug #6258: We can't use different version of a Technique on a given nodeRejectedFrançois ARMAND2015-02-12Actions
Blocked by Rudder - Architecture #2519: Upgrade CFEngine to 3.4.xReleased2012-06-07Actions
Actions #1

Updated by Jonathan CLARKE almost 12 years ago

  • Category changed from Techniques to 14
  • Status changed from In progress to Discussion
  • Assignee deleted (Jonathan CLARKE)
  • Target version changed from 18 to 24

This will not be fixed in 2.4. It needs thought and discussion in the light of the future of the Techniques repo.

Actions #2

Updated by Jonathan CLARKE over 11 years ago

  • Target version changed from 24 to 2.6.0~beta1
Actions #3

Updated by François ARMAND over 11 years ago

  • Assignee set to Nicolas CHARLES

Nicolas will be looking to that ticket, but it requieres to use CFEngine 3.4 and namespaces to be solved.

Actions #4

Updated by François ARMAND over 11 years ago

  • Status changed from Discussion to 8
Actions #5

Updated by Nicolas PERRON about 11 years ago

  • Target version changed from 2.6.0~beta1 to 2.6.0~rc1
Actions #6

Updated by Matthieu CERDA about 11 years ago

  • Target version changed from 2.6.0~rc1 to 2.6.0
Actions #7

Updated by Jonathan CLARKE about 11 years ago

  • Target version changed from 2.6.0 to 2.6.1
Actions #8

Updated by Nicolas PERRON about 11 years ago

  • Target version changed from 2.6.1 to 2.6.2
Actions #9

Updated by Nicolas PERRON about 11 years ago

  • Target version changed from 2.6.2 to 2.6.3
Actions #10

Updated by Nicolas PERRON almost 11 years ago

  • Target version changed from 2.6.3 to 2.6.4
Actions #11

Updated by Nicolas PERRON almost 11 years ago

Don't you see this issue on Rudder 2.4 ?

Actions #12

Updated by Nicolas PERRON almost 11 years ago

  • Target version changed from 2.6.4 to 2.6.5
Actions #13

Updated by Nicolas PERRON almost 11 years ago

  • Target version changed from 2.6.5 to 2.6.6
Actions #14

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.6.6 to 2.6.7
Actions #15

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.6.7 to 2.6.8
Actions #16

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.6.8 to 2.6.9
Actions #17

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.6.9 to 2.6.10
Actions #18

Updated by Vincent MEMBRÉ over 10 years ago

  • Target version changed from 2.6.10 to 2.6.11
Actions #19

Updated by Vincent MEMBRÉ over 10 years ago

  • Target version changed from 2.6.11 to 2.6.12
Actions #20

Updated by Vincent MEMBRÉ about 10 years ago

  • Target version changed from 2.6.12 to 2.6.13
Actions #21

Updated by Vincent MEMBRÉ about 10 years ago

  • Target version changed from 2.6.13 to 2.6.14
Actions #22

Updated by Jonathan CLARKE about 10 years ago

  • Target version changed from 2.6.14 to 2.6.16
Actions #23

Updated by Jonathan CLARKE almost 10 years ago

  • Target version changed from 2.6.16 to 2.6.17
Actions #24

Updated by Nicolas PERRON almost 10 years ago

  • Target version changed from 2.6.17 to 2.6.18
Actions #25

Updated by Matthieu CERDA over 9 years ago

  • Target version changed from 2.6.18 to 2.6.19
Actions #26

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.6.19 to 2.6.20
Actions #27

Updated by François ARMAND over 9 years ago

  • Status changed from 8 to Rejected
  • Target version changed from 2.6.20 to 2.10.10

In 2.10 and up, we have an error message at generation time: "There are directives based on techniques with different versions applied to the same node, please correct the version for the following directive(s): XXX".

So closing that bug.

Actions #28

Updated by François ARMAND over 9 years ago

  • Subject changed from When applying two versions of a same Techniques to the same note, a bundle name collision occurs to We can't use different version of a Technique on a given node
  • Description updated (diff)
  • Status changed from Rejected to New
  • Priority changed from 2 to 1
  • Target version changed from 2.10.10 to 2.10.11

OK, the bug as it stands is not corrected. The problem was not that there wasn't an explanation, but that it is not possible to use several Techniques version on a node.

So in fact, this ticket is duplicated by #6258.

Reopengin it with a major importance.

Actions #29

Updated by François ARMAND over 9 years ago

  • Subject changed from We can't use different version of a Technique on a given node to We can't use several versions of a Technique on a given node
Actions #30

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.11 to 2.10.12
Actions #31

Updated by Benoît PECCATTE over 9 years ago

  • Category changed from 14 to Web - Config management
Actions #32

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.12 to 2.10.13
Actions #33

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.13 to 2.10.14
Actions #34

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.14 to 2.10.15
Actions #35

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.15 to 2.10.16
Actions #36

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.16 to 2.10.17
Actions #37

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.17 to 2.10.18
Actions #38

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.18 to 2.10.19
Actions #39

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.19 to 2.10.20
Actions #40

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.20 to 2.11.18
Actions #41

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #42

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #43

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #44

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #45

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #46

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #47

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.24 to 308
Actions #48

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 308 to 3.1.14
Actions #49

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #50

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #51

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #52

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #53

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #54

Updated by Benoît PECCATTE over 7 years ago

  • Tracker changed from Bug to User story
Actions #55

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
Actions #56

Updated by François ARMAND about 7 years ago

  • Tracker changed from User story to Bug
  • Assignee deleted (Nicolas CHARLES)
  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
  • Effort required set to Very large
  • Reproduced set to No
  • Priority set to 0

I'm inclined to make that ticket as a bug. It is totally non expected for user to not be able to do that, and a very clear limitation without workaround that make other totally normal use case, like technique migration, a nightmare.

Actions #57

Updated by Alexis Mousset about 7 years ago

  • Related to User story #4293: Migrating from a Technique version to another one in a Directive is long and painful added
Actions #58

Updated by François ARMAND about 7 years ago

  • Subject changed from We can't use several versions of a Technique on a given node to We can't apply Directives from different versions of the same Technique on a node
  • Description updated (diff)
Actions #59

Updated by François ARMAND about 7 years ago

  • Related to Architecture #10625: Don't merge directive from same technique on generation added
Actions #60

Updated by François ARMAND about 7 years ago

  • Related to Bug #10580: Cannot mix audit/enforce mode on directives based on the same technique added
Actions #61

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.20 to 3.1.21
Actions #62

Updated by François ARMAND about 7 years ago

  • Priority changed from 0 to 6
Actions #63

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.21 to 3.1.22
Actions #64

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.22 to 3.1.23
Actions #65

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.23 to 3.1.24
Actions #66

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.24 to 3.1.25
Actions #67

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.25 to 387
Actions #68

Updated by Nicolas CHARLES over 6 years ago

  • Status changed from New to Rejected

This was done in #10625

Actions #69

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 387 to 3.1.25
Actions

Also available in: Atom PDF