Project

General

Profile

Actions

Bug #3140

closed

Reporting on CheckGenericFileContent is invalid when there is no content to add

Added by Nicolas CHARLES over 9 years ago. Updated over 7 years ago.

Status:
Released
Priority:
2
Category:
Techniques
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:

Description

Following #2819 and #3069, it's not mandatory to have content to add
However, if we don't have content to had, no edition is done, and no reports is sent for the component File, leading to "No Answer" reports

The bug exists in Rudder 2.3, for version 3.0 and 3.1

Actions #1

Updated by Nicolas CHARLES over 9 years ago

  • Status changed from New to In progress
Actions #2

Updated by Nicolas CHARLES over 9 years ago

  • Status changed from In progress to Rejected

I can't reproduce this error anymore... I guess it was a mistake from myself

Actions #3

Updated by Jonathan CLARKE over 9 years ago

  • Status changed from Rejected to 8

I've found this: if the class "edit_content_$(index)" is false, there is no reporting.

Actions #4

Updated by Nicolas CHARLES over 9 years ago

And it's true for 3.0, 3.1 and 3.2

Actions #5

Updated by Nicolas CHARLES over 9 years ago

  • Status changed from 8 to Pending technical review
  • Assignee changed from Nicolas CHARLES to Jonathan CLARKE
Actions #6

Updated by Nicolas CHARLES over 9 years ago

  • Status changed from Pending technical review to Pending release
  • % Done changed from 0 to 100

Applied in changeset commit:b7e4c6945238641b3823b1262c4a32aa0265f858.

Actions #7

Updated by Jonathan CLARKE over 9 years ago

Applied in changeset commit:7f8c4c820aa432f83aed7dc3ec199b4580be19a8.

Actions #8

Updated by Nicolas PERRON over 9 years ago

Applied in changeset commit:c6e8bb7c6439a16ebb4bc020612188fd5da244ff.

Actions #9

Updated by Nicolas PERRON over 9 years ago

Applied in changeset commit:63721341c37136d714ecc163bd49cf725d40584f.

Actions #10

Updated by Jonathan CLARKE over 9 years ago

  • Project changed from Rudder to 24
  • Category deleted (Techniques)
Actions #11

Updated by Nicolas PERRON over 9 years ago

  • Status changed from Pending release to Released
Actions #12

Updated by Benoît PECCATTE over 7 years ago

  • Project changed from 24 to Rudder
  • Category set to Techniques
Actions

Also available in: Atom PDF