Project

General

Profile

Actions

User story #3253

closed

Techniques "RUG / YaST package manager configuration (ZMD)" and "Zypper package manager configuration" should be split in three: two for configuring Rug /YaST and Zypper, the last one to configure repositories

Added by Nicolas PERRON over 9 years ago. Updated over 7 years ago.

Status:
Released
Priority:
1
Assignee:
Nicolas PERRON
Category:
Techniques
Target version:
UX impact:
Suggestion strength:
User visibility:
Effort required:
Regression:

Description

Actually, the Technique RUG / YaST package manager configuration (ZMD) has a logic which consist in configuring all about Rug/ YaST and Zypper package manager configuration has the same logic for Zypper.

This way to configure Package managers can't work for now since we have limitations on reporting when sub-section multivalued need reporting as other sections none multivalued.

Besides, configuration of repositories is common to all package manager then we should have one Technique for at least all RPM systems.


Subtasks 1 (0 open1 closed)

User story #3254: Split Techniques "RUG / YaST package manager configuration (ZMD)" and "Zypper package manager configuration" in three: two for configuring Rug /YaST and Zypper and one for repositories managementReleasedJonathan CLARKE2013-02-11Actions

Related issues 1 (0 open1 closed)

Related to Rudder - Bug #3170: Techniques 'Zypper Package Manager Configuration' and 'RUG / YaST package manager configuration (ZMD)': Broken Reporting when configuration more than one repository which should not be addedReleasedNicolas CHARLES2013-01-10Actions
Actions #1

Updated by Nicolas PERRON over 9 years ago

#3170 can't be handled before #3254, since reporting can't work in the actual state of the Technique Zypper package manager configuration

Actions #2

Updated by Nicolas PERRON over 9 years ago

  • Status changed from New to 13
  • Target version changed from 2.6.0~beta1 to 2.6.0~rc1
Actions #3

Updated by Jonathan CLARKE over 9 years ago

  • Target version changed from 2.6.0~rc1 to 2.6.0
Actions #4

Updated by Jonathan CLARKE over 9 years ago

  • Target version changed from 2.6.0 to 2.6.1
Actions #5

Updated by Nicolas PERRON over 9 years ago

  • Target version changed from 2.6.1 to 2.6.2
Actions #6

Updated by Nicolas PERRON over 9 years ago

  • Target version changed from 2.6.2 to 2.6.3
Actions #7

Updated by Nicolas PERRON about 9 years ago

  • Target version changed from 2.6.3 to 2.6.4
Actions #8

Updated by Nicolas PERRON about 9 years ago

  • Target version changed from 2.6.4 to 2.6.5
Actions #9

Updated by Nicolas PERRON about 9 years ago

  • Status changed from 13 to Pending release
Actions #10

Updated by Nicolas PERRON about 9 years ago

  • Status changed from Pending release to Discussion
  • Target version changed from 2.6.5 to 2.4.9

This change has been reverted and should be reworked to be added in 2.4.

Actions #11

Updated by Nicolas PERRON about 9 years ago

  • Target version changed from 2.4.9 to 2.4.10
Actions #12

Updated by Nicolas PERRON almost 9 years ago

  • Target version changed from 2.4.10 to 2.4.11
Actions #13

Updated by Nicolas PERRON almost 9 years ago

  • Target version changed from 2.4.11 to 2.4.12
Actions #14

Updated by Nicolas PERRON almost 9 years ago

  • Target version changed from 2.4.12 to 2.4.13
Actions #15

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.4.13 to 2.6.11

Retargeting to 2.6, since 2.4 is not maintained anymore

Actions #16

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.6.11 to 2.6.12
Actions #17

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.6.12 to 2.6.13
Actions #18

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.6.13 to 2.6.14
Actions #19

Updated by Jonathan CLARKE over 8 years ago

  • Target version changed from 2.6.14 to 2.6.16
Actions #20

Updated by Jonathan CLARKE over 8 years ago

  • Target version changed from 2.6.16 to 2.6.17
Actions #21

Updated by Nicolas PERRON about 8 years ago

  • Target version changed from 2.6.17 to 2.6.18
Actions #22

Updated by Jonathan CLARKE about 8 years ago

  • Status changed from Discussion to Rejected

See #3254 for status.

Actions #23

Updated by Matthieu CERDA almost 8 years ago

  • Status changed from Rejected to Released

This bug has been fixed in Rudder 2.6.18, which was released today.
Check out:

Actions #24

Updated by Benoît PECCATTE over 7 years ago

  • Project changed from 24 to Rudder
  • Category changed from Techniques to Techniques
Actions

Also available in: Atom PDF