Project

General

Profile

Bug #3431

At first start of Rudder Webapp, no connection to LDAP to be valid since it is not possible to see the Technique User Library Tree

Added by Nicolas PERRON over 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
System techniques
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:

Description

At first start of Rudder WebUI, it is not possible to see Techniquer User Library Tree and in the logs, we have theses messages:

[2013-04-12 11:26:28] ERROR com.normation.rudder.web.snippet.configuration.TechniqueLibraryManagement - Error when trying to get the root category of Active Techniques <- Can't get a new LDAP connection
[2013-04-12 11:26:28] ERROR com.normation.rudder.web.snippet.configuration.TechniqueLibraryManagement - Exception causing the error was:
com.unboundid.ldap.sdk.LDAPException: invalid credentials

It could be because CFEngine change LDAP credentials after jetty has been restarted.

History

#1 Updated by Matthieu CERDA over 5 years ago

  • Target version changed from 2.6.0~rc1 to 2.6.0

#2 Updated by Jonathan CLARKE over 5 years ago

  • Target version changed from 2.6.0 to 2.6.1

#3 Updated by Nicolas PERRON over 5 years ago

  • Target version changed from 2.6.1 to 2.6.2

#4 Updated by Nicolas PERRON over 5 years ago

  • Target version changed from 2.6.2 to 2.6.3

#5 Updated by Nicolas PERRON over 5 years ago

  • Target version changed from 2.6.3 to 2.6.4

#6 Updated by Nicolas PERRON over 5 years ago

  • Target version changed from 2.6.4 to 2.6.5

#7 Updated by Nicolas PERRON over 5 years ago

  • Target version changed from 2.6.5 to 2.6.6

#8 Updated by Nicolas PERRON about 5 years ago

  • Target version changed from 2.6.6 to 2.4.10

#9 Updated by Nicolas PERRON about 5 years ago

  • Target version changed from 2.4.10 to 2.6.7

#10 Updated by Nicolas PERRON about 5 years ago

  • Target version changed from 2.6.7 to 2.6.8

#11 Updated by Nicolas PERRON about 5 years ago

  • Target version changed from 2.6.8 to 2.6.9

#12 Updated by Nicolas PERRON about 5 years ago

  • Target version changed from 2.6.9 to 2.6.10

#13 Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.6.10 to 2.6.11

#14 Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.6.11 to 2.6.12

#15 Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.6.12 to 2.6.13

#16 Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.6.13 to 2.6.14

#17 Updated by Jonathan CLARKE over 4 years ago

  • Target version changed from 2.6.14 to 2.6.16

#18 Updated by Jonathan CLARKE over 4 years ago

  • Target version changed from 2.6.16 to 2.6.17

#19 Updated by Nicolas PERRON over 4 years ago

  • Target version changed from 2.6.17 to 2.6.18

#20 Updated by Matthieu CERDA about 4 years ago

  • Target version changed from 2.6.18 to 2.6.19

#21 Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.6.19 to 2.6.20

#22 Updated by François ARMAND almost 4 years ago

  • Target version changed from 2.6.20 to 2.10.10

I was not able to reproduce that one in 2.10/2.11/3.0, so closing it.

#23 Updated by François ARMAND almost 4 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF