Project

General

Profile

Actions

Bug #3605

closed

Each time we visit the Event Log page, the used memory of Rudder goes up, and don't seem to be GCed

Added by Nicolas CHARLES over 9 years ago. Updated about 8 years ago.

Status:
Released
Priority:
3
Category:
Web - Maintenance
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Regression:

Description

I've noticed that when I go on the Event Log page, the Old space utilization of the JVM grows by around 8 MB, and is never reclaimed after. Login out doesn't free the memory; there must be something wrong going on.
After a while (eating 800 MB), two full garbage collection occurs, and we returns to 100 MB Old Space Utilisation

Happens on all versions of Rudder

Actions #1

Updated by Nicolas CHARLES over 9 years ago

Displaying empty pages leads to the same memory usage. So it is probably not linked to that

Remark : there were only 2 FGC runnning before this test, and the app was running for a bit more than 16 hours

Actions #2

Updated by Nicolas CHARLES over 9 years ago

  • Assignee deleted (Nicolas CHARLES)
Actions #3

Updated by Nicolas PERRON over 9 years ago

  • Target version changed from 2.3.13 to 84
Actions #4

Updated by Nicolas PERRON over 9 years ago

  • Target version changed from 84 to 2.4.7
Actions #5

Updated by Nicolas PERRON over 9 years ago

  • Target version changed from 2.4.7 to 2.4.8
Actions #6

Updated by Nicolas PERRON about 9 years ago

  • Target version changed from 2.4.8 to 2.4.9
Actions #7

Updated by Nicolas PERRON about 9 years ago

  • Target version changed from 2.4.9 to 2.4.10
Actions #8

Updated by Nicolas PERRON about 9 years ago

  • Target version changed from 2.4.10 to 2.4.11
Actions #9

Updated by Nicolas PERRON about 9 years ago

  • Target version changed from 2.4.11 to 2.4.12
Actions #10

Updated by Nicolas PERRON about 9 years ago

  • Status changed from New to Discussion
  • Assignee set to Nicolas CHARLES

Nicolas CHARLES wrote:

Displaying empty pages leads to the same memory usage. So it is probably not linked to that

Remark : there were only 2 FGC runnning before this test, and the app was running for a bit more than 16 hours

Is there any clue, now ?

Actions #11

Updated by Nicolas PERRON about 9 years ago

  • Target version changed from 2.4.12 to 2.4.13
Actions #12

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.4.13 to 2.6.11

Since 2.4 is not maintained anymore, retargeting to branch 2.6

Actions #13

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.6.11 to 2.6.12
Actions #14

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.6.12 to 2.6.13
Actions #15

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.6.13 to 2.6.14
Actions #16

Updated by Jonathan CLARKE over 8 years ago

  • Target version changed from 2.6.14 to 2.6.16
Actions #17

Updated by Jonathan CLARKE over 8 years ago

  • Target version changed from 2.6.16 to 2.6.17
Actions #18

Updated by Nicolas PERRON over 8 years ago

  • Target version changed from 2.6.17 to 2.6.18
Actions #19

Updated by Nicolas CHARLES over 8 years ago

  • Status changed from Discussion to Rejected

i never was able to reproduce it any more. I'm rejecting it, will reopen it if it appears again

Actions #20

Updated by Matthieu CERDA about 8 years ago

  • Status changed from Rejected to Released

This bug has been fixed in Rudder 2.6.18, which was released today.
Check out:

Actions

Also available in: Atom PDF