Project

General

Profile

Actions

Bug #3646

closed

Technique "Dowload a file from shared-folder" is not working properly with a source file and a directory as destination

Added by Vincent MEMBRÉ about 11 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
2
Category:
Techniques
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Name check:
Fix check:
Regression:

Description

When using technique "Download a file from shared-folder", I want to copy a file in a directory so i configured my directive like this:

Path of the file to be copied: toto.test.txt
Destination of the file : /test_rudder/soft/sources/httpd/
What should be the recursion level of the copy : only this file
File comparison method : Exists
Owner of the file : root
Group of the file : root
Permission to apply : user RWX / group R-X / other ---

And this in not working.
I expect this to copy "toto.test.txt" in "/test_rudder/soft/sources/httpd/" and apply permissions on "/test_rudder/soft/sources/httpd/toto.test.txt"

This is not what is happenning:

the file is not copied in the destination directory. and permissions are applied to the directory and to all its files.
And it's reporting success ... So its mostly lying :)

We shoudl treat that case when the source is a "file" and the destination is a "directory" it should copy on "directory/file" and apply permissions on that file only


Related issues 3 (1 open2 closed)

Related to Rudder - Bug #4334: Technique "Download From A Shared Folder": copy files to directory destination doesn't workRejectedActions
Related to Rudder - Bug #4354: Technique "Download a file from the shared folder": Explanation about which files will be copied are not correctReleasedJonathan CLARKE2014-01-13Actions
Is duplicate of Rudder - Bug #7799: directories are not replaced by a file with the same name during file copyNewActions
Actions #1

Updated by Nicolas PERRON almost 11 years ago

  • Target version changed from 2.4.7 to 2.4.8
Actions #2

Updated by Nicolas PERRON almost 11 years ago

  • Target version changed from 2.4.8 to 2.4.9
Actions #3

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.9 to 2.4.10
Actions #4

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.10 to 2.4.11
Actions #5

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.11 to 2.4.12
Actions #6

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.12 to 2.4.13
Actions #7

Updated by Nicolas PERRON over 10 years ago

This bug could lead to #4334 by mistake

Actions #8

Updated by Jonathan CLARKE over 10 years ago

  • Status changed from New to 8
  • Priority changed from 1 to 2
  • Target version changed from 2.4.13 to 2.6.10

Confirmed.

Actions #9

Updated by Vincent MEMBRÉ over 10 years ago

  • Target version changed from 2.6.10 to 2.6.11
Actions #10

Updated by Vincent MEMBRÉ over 10 years ago

  • Target version changed from 2.6.11 to 2.6.12
Actions #11

Updated by Vincent MEMBRÉ about 10 years ago

  • Target version changed from 2.6.12 to 2.6.13
Actions #12

Updated by Vincent MEMBRÉ about 10 years ago

  • Target version changed from 2.6.13 to 2.6.14
Actions #13

Updated by Jonathan CLARKE about 10 years ago

  • Target version changed from 2.6.14 to 2.6.16
Actions #14

Updated by Jonathan CLARKE almost 10 years ago

  • Target version changed from 2.6.16 to 2.6.17
Actions #15

Updated by Nicolas PERRON almost 10 years ago

  • Target version changed from 2.6.17 to 2.6.18
Actions #16

Updated by Matthieu CERDA over 9 years ago

  • Target version changed from 2.6.18 to 2.6.19
Actions #17

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.6.19 to 2.6.20
Actions #18

Updated by François ARMAND over 9 years ago

  • Target version changed from 2.6.20 to 2.10.10
Actions #19

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.10 to 2.10.11
Actions #20

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.11 to 2.10.12
Actions #21

Updated by Benoît PECCATTE over 9 years ago

  • Project changed from 24 to Rudder
  • Category changed from Techniques to Techniques
Actions #22

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.12 to 2.10.13
Actions #23

Updated by Benoît PECCATTE about 9 years ago

  • Status changed from 8 to New
Actions #24

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.13 to 2.10.14
Actions #25

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.14 to 2.10.15
Actions #26

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.15 to 2.10.16
Actions #27

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.16 to 2.10.17
Actions #28

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.17 to 2.10.18
Actions #29

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.18 to 2.10.19
Actions #30

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.19 to 2.10.20
Actions #31

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.20 to 2.11.18
Actions #32

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #33

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #34

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #35

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #36

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #37

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #38

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.24 to 308
Actions #39

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 308 to 3.1.14
Actions #40

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #41

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #42

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #43

Updated by François ARMAND over 7 years ago

  • Assignee set to Alexis Mousset

Is this still the case ?

Actions #44

Updated by Alexis Mousset over 7 years ago

I guess this is a duplicate of #7799

Actions #45

Updated by Alexis Mousset over 7 years ago

  • Status changed from New to Rejected
Actions #46

Updated by Alexis Mousset over 7 years ago

  • Is duplicate of Bug #7799: directories are not replaced by a file with the same name during file copy added
Actions

Also available in: Atom PDF