Project

General

Profile

Actions

Bug #3797

closed

The use of the deprecated API functions should not be able to be done with a version number higher than 1

Added by Nicolas PERRON over 9 years ago. Updated almost 8 years ago.

Status:
Released
Priority:
1
Category:
Packaging
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Regression:

Description

on Rudder 2.6, it was possible to use the API without version for some instructions like regeneration of CFEngine promises (api/deploy/reload). These API call are considered as Version "1" but now, it is still possible to call these API with any version.

We should forbid any use of API version other than "1" with these call.

Actions #1

Updated by Nicolas PERRON over 9 years ago

  • Target version set to 2.7.0
Actions #2

Updated by Nicolas PERRON over 9 years ago

  • Status changed from New to Pending technical review
  • % Done changed from 0 to 100
  • Pull Request set to https://github.com/Normation/rudder/pull/290

Pull Request URL added: https://github.com/Normation/rudder/pull/290

Jon, could you review it, please ?

Actions #3

Updated by Nicolas PERRON over 9 years ago

  • Assignee changed from Nicolas PERRON to Jonathan CLARKE
Actions #4

Updated by Nicolas PERRON over 9 years ago

  • Status changed from Pending technical review to Pending release
Actions #5

Updated by Nicolas PERRON over 9 years ago

  • Subject changed from The previous call of API should not be able to be done with the version 2 to The use of the deprecated API functions should not be able to be done with a version number higher than 1
Actions #6

Updated by Nicolas PERRON over 9 years ago

  • Status changed from Pending release to Released
Actions #7

Updated by Nicolas PERRON over 9 years ago

This bug has been fixed in Rudder 2.7.0, which was released today.
Check out:

Actions #8

Updated by Benoît PECCATTE almost 8 years ago

  • Project changed from 34 to Rudder
  • Category set to Packaging
Actions

Also available in: Atom PDF