Project

General

Profile

Actions

Bug #3814

closed

Attempting to install a non-existant package via yum should return an error (RHEL <= 5)

Added by Jonathan CLARKE almost 11 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
2
Assignee:
-
Category:
Techniques
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Infrequent - complex configurations | third party integrations
Effort required:
Priority:
41
Name check:
Fix check:
Regression:

Description

Currently, when we try and install a package that doesn't exist, apt-get and zypper complain about it (non-zero return code, which leads to an error in Rudder reporting). However, yum doesn't care, and just returns 0, making a "success" or "repaired" report in Rudder.

This is obviously misleading. We should find a way to check if a package exists before running "yum install", and report an error if it doesn't. An idea I have is to do something like "yum search <package name> | grep "^Warning: No matches found for: "" and see what we can do with that. Maybe we can build it into the "package_add_command" of the package_method.

Actions #1

Updated by Dennis Cabooter over 10 years ago

Probably this can be useful:

# rpm -qa | grep zsh
# yum list available zsh > /dev/null 2>&1
# echo $?
0
# yum list available bla > /dev/null 2>&1
# echo $?
1
Actions #2

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.8 to 2.4.9
Actions #3

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.9 to 2.4.10
Actions #4

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.10 to 2.4.11
Actions #5

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.11 to 2.4.12
Actions #6

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.12 to 2.4.13
Actions #7

Updated by Vincent MEMBRÉ over 10 years ago

  • Target version changed from 2.4.13 to 2.6.11

Since 2.4 is not maintained anymore, retargeting to branch 2.6

Actions #8

Updated by Vincent MEMBRÉ about 10 years ago

  • Target version changed from 2.6.11 to 2.6.12
Actions #9

Updated by Vincent MEMBRÉ about 10 years ago

  • Target version changed from 2.6.12 to 2.6.13
Actions #10

Updated by Vincent MEMBRÉ almost 10 years ago

  • Target version changed from 2.6.13 to 2.6.14
Actions #11

Updated by Jonathan CLARKE almost 10 years ago

  • Target version changed from 2.6.14 to 2.6.16
Actions #12

Updated by Jonathan CLARKE almost 10 years ago

  • Target version changed from 2.6.16 to 2.6.17
Actions #13

Updated by Nicolas PERRON almost 10 years ago

  • Target version changed from 2.6.17 to 2.6.18
Actions #14

Updated by Matthieu CERDA over 9 years ago

  • Target version changed from 2.6.18 to 2.6.19
Actions #15

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.6.19 to 2.6.20
Actions #16

Updated by François ARMAND over 9 years ago

  • Target version changed from 2.6.20 to 2.10.10
Actions #17

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.10 to 2.10.11
Actions #18

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.11 to 2.10.12
Actions #19

Updated by Benoît PECCATTE about 9 years ago

  • Project changed from 24 to Rudder
  • Category changed from Techniques to Techniques
Actions #20

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.12 to 2.10.13
Actions #21

Updated by Benoît PECCATTE about 9 years ago

  • Status changed from 8 to New
Actions #22

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.13 to 2.10.14
Actions #23

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.14 to 2.10.15
Actions #24

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.15 to 2.10.16
Actions #25

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.16 to 2.10.17
Actions #26

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.17 to 2.10.18
Actions #27

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.18 to 2.10.19
Actions #28

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.19 to 2.10.20
Actions #29

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.20 to 2.11.18
Actions #30

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #31

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #32

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #33

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #34

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #35

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #36

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.24 to 308
Actions #37

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 308 to 3.1.14
Actions #38

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #39

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #40

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #41

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #42

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #43

Updated by Jonathan CLARKE about 7 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
Actions #44

Updated by François ARMAND about 7 years ago

  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
Actions #45

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
  • Priority set to 0
Actions #46

Updated by Alexis Mousset about 7 years ago

It returns an error in CentOS/RHEL >= 6.

Actions #47

Updated by Benoît PECCATTE about 7 years ago

  • Status changed from New to In progress
  • Assignee set to Benoît PECCATTE
Actions #48

Updated by Benoît PECCATTE about 7 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Benoît PECCATTE to Vincent MEMBRÉ
  • Pull Request set to https://github.com/Normation/packaging/pull/192
Actions #49

Updated by Benoît PECCATTE about 7 years ago

  • Status changed from Pending technical review to New
  • Assignee deleted (Vincent MEMBRÉ)
Actions #50

Updated by Benoît PECCATTE about 7 years ago

  • Pull Request deleted (https://github.com/Normation/packaging/pull/192)
Actions #51

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.20 to 3.1.21
Actions #52

Updated by François ARMAND almost 7 years ago

  • Severity changed from Minor - inconvenience | misleading | easy workaround to Major - prevents use of part of Rudder | no simple workaround
  • User visibility changed from Operational - other Techniques | Technique editor | Rudder settings to Getting started - demo | first install | level 1 Techniques
  • Priority changed from 0 to 49
Actions #53

Updated by Jonathan CLARKE almost 7 years ago

  • Subject changed from Attempting to install a non-existant package via yum should return an error to Attempting to install a non-existant package via yum should return an error (RHEL <= 5)
  • User visibility changed from Getting started - demo | first install | level 1 Techniques to Infrequent - complex configurations | third party integrations
  • Priority changed from 49 to 23

According to Alexis this only happens on RHEL <= 5.

Actions #54

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.21 to 3.1.22
Actions #55

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 23 to 37
Actions #56

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.22 to 3.1.23
  • Priority changed from 37 to 38
Actions #57

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.23 to 3.1.24
Actions #58

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.24 to 3.1.25
Actions #59

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.25 to 387
  • Priority changed from 38 to 39
Actions #60

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 387 to 4.1.10
Actions #61

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.10 to 4.1.11
Actions #62

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
  • Priority changed from 39 to 40
Actions #63

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
Actions #64

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
  • Priority changed from 40 to 41
Actions #65

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
Actions #66

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.15 to 4.1.16
Actions #67

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
Actions #68

Updated by François ARMAND over 5 years ago

  • Status changed from New to Rejected

Closing that ticket because honestly, we won't ever correct it: it's a yum problem on a non supported distro. If you are impacted, please contact us, we are very interested about your use case!

Actions

Also available in: Atom PDF