Project

General

Profile

Bug #3917

Archiving reports should not break on on duplicate IDs or key

Added by Nicolas CHARLES about 6 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
2
Category:
Web - Compliance & node report
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:

Description

When Rudder automatically archives reports, it does it in 3 step:
  1. copy from ruddersysevents to archivedreports
  2. delete from ruddersysevents
  3. vaccumm

If the webapp is stopped between 1 and 2, we have the archive in an invalid state, causing it to fail later as it tries to insert already existing entries into the archivedruddersysevents.

In fact, we want to be able to have the archived execution reports on an other DB, so we don't want to add transaction, but be smart about how we handle already migrated reports.


Related issues

Is duplicate of Rudder - Bug #10171: If the Rudder Web Interface is interrupted during the second step of reports archiving, then it won't never succeed in archiving againReleasedActions

History

#1

Updated by François ARMAND about 6 years ago

  • Subject changed from The reports archive are not transactionnal to Archiving reports should not break on on duplicate IDs or key
  • Description updated (diff)
#2

Updated by Nicolas PERRON about 6 years ago

  • Target version changed from 2.6.6 to 2.4.10
#3

Updated by Nicolas PERRON about 6 years ago

  • Target version changed from 2.4.10 to 2.6.7
#4

Updated by Nicolas PERRON about 6 years ago

  • Target version changed from 2.6.7 to 2.6.8
#5

Updated by Nicolas PERRON about 6 years ago

  • Target version changed from 2.6.8 to 2.6.9
#6

Updated by Nicolas PERRON almost 6 years ago

  • Priority changed from N/A to 2
  • Target version changed from 2.6.9 to 2.6.10

It seems important.

#7

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 2.6.10 to 2.6.11
#8

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.6.11 to 2.6.12
#9

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.6.12 to 2.6.13
#10

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.6.13 to 2.6.14
#11

Updated by Jonathan CLARKE over 5 years ago

  • Target version changed from 2.6.14 to 2.6.16
#12

Updated by Jonathan CLARKE over 5 years ago

  • Target version changed from 2.6.16 to 2.6.17
#13

Updated by Nicolas PERRON about 5 years ago

  • Target version changed from 2.6.17 to 2.6.18
#14

Updated by Matthieu CERDA about 5 years ago

  • Target version changed from 2.6.18 to 2.6.19
#15

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.6.19 to 2.6.20
#16

Updated by François ARMAND over 4 years ago

  • Assignee set to Nicolas CHARLES
  • Target version changed from 2.6.20 to 2.10.10

Nico, I think it's not more the case in 2.10. Could you confirm, and if so closed the ticket ?

#17

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.10 to 2.10.11
#18

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.11 to 2.10.12
#19

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.12 to 2.10.13
#20

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.13 to 2.10.14
#21

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.14 to 2.10.15
#22

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.15 to 2.10.16
#23

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.10.16 to 2.10.17
#24

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.10.17 to 2.10.18
#25

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.10.18 to 2.10.19
#26

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.10.19 to 2.10.20
#27

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.10.20 to 2.11.18
#28

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.11.18 to 2.11.19
#29

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.11.19 to 2.11.20
#30

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.11.20 to 2.11.21
#31

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.11.21 to 2.11.22
#32

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.11.22 to 2.11.23
#33

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.11.23 to 2.11.24
#34

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.11.24 to 308
#35

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 308 to 3.1.14
#36

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 3.1.14 to 3.1.15
#37

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 3.1.15 to 3.1.16
#38

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 3.1.16 to 3.1.17
#39

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 3.1.17 to 3.1.18
#40

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 3.1.18 to 3.1.19
#41

Updated by François ARMAND over 2 years ago

  • Has duplicate Bug #10171: If the Rudder Web Interface is interrupted during the second step of reports archiving, then it won't never succeed in archiving again added
#42

Updated by François ARMAND over 2 years ago

  • Has duplicate deleted (Bug #10171: If the Rudder Web Interface is interrupted during the second step of reports archiving, then it won't never succeed in archiving again)
#43

Updated by François ARMAND over 2 years ago

  • Is duplicate of Bug #10171: If the Rudder Web Interface is interrupted during the second step of reports archiving, then it won't never succeed in archiving again added
#44

Updated by François ARMAND over 2 years ago

  • Status changed from New to Rejected

This was corrected in #10171

Also available in: Atom PDF