Project

General

Profile

Bug #3983

Technique rpmPackageInstallation versions 4.1 and 5.0 have diverged

Added by Jonathan CLARKE over 6 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
4
Category:
Techniques
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:

Description

#3793 introduced rpmPackageInstallation/4.1 on branches 2.6+, and then #3934 backported it to 2.4 branch.

However, in the mean time, #1175 introduced a 5.0 version across all 2.4+ branches.

These two versions are separate evolutions from 4.0. A new version should be made that incorporates changes from 4.1 and 5.0 together.

#1

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.4.10 to 2.4.11
#2

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.4.11 to 2.4.12
#3

Updated by Nicolas PERRON over 6 years ago

  • Target version changed from 2.4.12 to 2.4.13
#4

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.4.13 to 2.6.11

Since version 2.4 is not maintained anymore, retargeting to branch 2.6

#5

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.6.11 to 2.6.12
#6

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.6.12 to 2.6.13
#7

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 2.6.13 to 2.6.14
#8

Updated by Jonathan CLARKE almost 6 years ago

  • Target version changed from 2.6.14 to 2.6.16
#9

Updated by Jonathan CLARKE almost 6 years ago

  • Target version changed from 2.6.16 to 2.6.17
#10

Updated by Nicolas PERRON almost 6 years ago

  • Target version changed from 2.6.17 to 2.6.18
#11

Updated by Matthieu CERDA over 5 years ago

  • Target version changed from 2.6.18 to 2.6.19
#12

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.6.19 to 2.6.20
#13

Updated by François ARMAND over 5 years ago

  • Assignee set to Benoît PECCATTE
  • Priority changed from 2 to 4
  • Target version changed from 2.6.20 to 2.10.10

Benoit, is it still the case ? Can you confirm ? And if so, we need to know what to do given that these two versions are deprecated in 3.0...

#14

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.10.10 to 2.10.11
#15

Updated by Benoît PECCATTE over 5 years ago

  • Status changed from 8 to Discussion

This is still the case.
To be short we should do : diff -r 4.0 4.1 | patch 7.1

And the diff is pretty short.

#16

Updated by François ARMAND over 5 years ago

OK, so I think we need to correct the divergence with new version of each one, and up. What do you think Benoit ?

#17

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.11 to 2.10.12
#18

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.12 to 2.10.13
#19

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.13 to 2.10.14
#20

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.10.14 to 2.10.15
#21

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.10.15 to 2.10.16
#22

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.10.16 to 2.10.17
#23

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.17 to 2.10.18
#24

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.18 to 2.10.19
#25

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.19 to 2.10.20
#26

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.10.20 to 2.11.18
#27

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.18 to 2.11.19
#28

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.19 to 2.11.20
#29

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.11.20 to 2.11.21
#30

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.11.21 to 2.11.22
#31

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.11.22 to 2.11.23
#32

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.11.23 to 2.11.24
#33

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.11.24 to 308
#34

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 308 to 3.1.14
#35

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.14 to 3.1.15
#36

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.15 to 3.1.16
#37

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.16 to 3.1.17
#38

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.17 to 3.1.18
#39

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.18 to 3.1.19
#40

Updated by Alexis MOUSSET about 3 years ago

  • Status changed from Discussion to Rejected

The only supported version is 7.0, and it is now deprecated, closing.

Also available in: Atom PDF