Project

General

Profile

Actions

User story #4363

closed

Rename all services installed by rudder-* packages "rudder-*" (init scripts)

Added by Jonathan CLARKE over 10 years ago. Updated about 9 years ago.

Status:
Rejected
Priority:
3
Assignee:
Matthieu CERDA
Category:
Packaging
Target version:
UX impact:
Suggestion strength:
User visibility:
Effort required:
Name check:
Fix check:
Regression:

Description

Currently, the rudder-server-root package pulls in several dependencies, lots of which come from rudder-* packages. These include several system services that are not names rudder-*, such as: slapd and jetty.

These are hard to find for users not used to Rudder, and they often miss them completely. Since we install these applications under /opt/rudder anyway, we should go ahead and change the init script name to make them easier to find, and more friendly in case there is already a slapd or jetty installed on that machine in a different path.

It's worth checking we don't install any others - I just mention slapd and jetty off the top of my head.


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - User story #4510: Rename jetty and slapd init scripts and defaults files to rudder-jetty and rudder-slapdReleasedMatthieu CERDA2014-02-25Actions
Actions #1

Updated by Matthieu CERDA over 10 years ago

  • Status changed from New to 8
  • Assignee set to Matthieu CERDA
  • Priority changed from N/A to 3
Actions #2

Updated by Matthieu CERDA over 10 years ago

  • Status changed from 8 to Rejected

This has been duplicated by #4510. Rejecting :)

Actions #3

Updated by Benoît PECCATTE about 9 years ago

  • Project changed from 34 to Rudder
  • Category set to Packaging
Actions

Also available in: Atom PDF