Project

General

Profile

Bug #4400

Process start date are displayed as "bad format" in Rudder web interface

Added by François ARMAND about 6 years ago. Updated almost 5 years ago.

Status:
Released
Priority:
3
Category:
Web - Nodes & inventories
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

Quite frequently, the "started on" column for the "processes" tab in node details view is full of "Bad format" in place of a date.

This can be due to two causes:

- we actually don't have the date, in which case we MUST display that information in place of "bad format",
- we had a date in the inventory report, but not in the the iso-8601 short format, what happens most of the time. In that case, we should just keep the date. Better to have something a human can try to parse with its brain than nothing at all.


Subtasks

Bug #4402: Process start date are not parsed correctly when parsing inventory fileReleased2014-01-23Nicolas CHARLESActions

Related issues

Related to Rudder - Bug #4742: Process start date are displayed as "bad format" in Rudder web interfaceReleased2014-04-08François ARMANDActions
#1

Updated by François ARMAND about 6 years ago

  • Pull Request set to https://github.com/Normation/rudder/pull/431
#2

Updated by François ARMAND about 6 years ago

  • Status changed from 8 to Pending release
#4

Updated by Vincent MEMBRÉ almost 6 years ago

  • Subject changed from "Bad format" in inventories for process to Process start date are displayed as "bad format" in Rudder web interface
#5

Updated by Vincent MEMBRÉ almost 6 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 2.6.11, which was released today.
Check out:

#6

Updated by Benoît PECCATTE almost 5 years ago

  • Category changed from 26 to Web - Nodes & inventories

Also available in: Atom PDF