Project

General

Profile

Actions

Bug #4400

closed

Process start date are displayed as "bad format" in Rudder web interface

Added by François ARMAND about 9 years ago. Updated almost 8 years ago.

Status:
Released
Priority:
3
Category:
Web - Nodes & inventories
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Regression:

Description

Quite frequently, the "started on" column for the "processes" tab in node details view is full of "Bad format" in place of a date.

This can be due to two causes:

- we actually don't have the date, in which case we MUST display that information in place of "bad format",
- we had a date in the inventory report, but not in the the iso-8601 short format, what happens most of the time. In that case, we should just keep the date. Better to have something a human can try to parse with its brain than nothing at all.


Subtasks 1 (0 open1 closed)

Bug #4402: Process start date are not parsed correctly when parsing inventory fileReleasedNicolas CHARLES2014-01-23Actions

Related issues 1 (0 open1 closed)

Related to Rudder - Bug #4742: Process start date are displayed as "bad format" in Rudder web interfaceReleasedFrançois ARMAND2014-04-08Actions
Actions #1

Updated by François ARMAND about 9 years ago

  • Pull Request set to https://github.com/Normation/rudder/pull/431
Actions #2

Updated by François ARMAND about 9 years ago

  • Status changed from 8 to Pending release
Actions #4

Updated by Vincent MEMBRÉ almost 9 years ago

  • Subject changed from "Bad format" in inventories for process to Process start date are displayed as "bad format" in Rudder web interface
Actions #5

Updated by Vincent MEMBRÉ almost 9 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 2.6.11, which was released today.
Check out:

Actions #6

Updated by Benoît PECCATTE almost 8 years ago

  • Category changed from 26 to Web - Nodes & inventories
Actions

Also available in: Atom PDF