Project

General

Profile

Bug #4461

Some typo in windows support in system Techniques

Added by Nicolas CHARLES almost 5 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
N/A
Category:
System techniques
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:

Description

The system Technique are missing the rudder_rm definition on windows; and lists of cfengine components are missing the .exe in their name


Related issues

Is duplicate of Rudder - Bug #6550: On windows node inventory files are not deletedRejected

History

#1 Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.6.11 to 2.6.12

#2 Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.6.12 to 2.6.13

#3 Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.6.13 to 2.6.14

#4 Updated by Jonathan CLARKE over 4 years ago

  • Target version changed from 2.6.14 to 2.6.16

#5 Updated by Jonathan CLARKE over 4 years ago

  • Target version changed from 2.6.16 to 2.6.17

#6 Updated by Nicolas PERRON over 4 years ago

  • Target version changed from 2.6.17 to 2.6.18

#7 Updated by Matthieu CERDA about 4 years ago

  • Target version changed from 2.6.18 to 2.6.19

#8 Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.6.19 to 2.6.20

#9 Updated by François ARMAND almost 4 years ago

  • Assignee set to Nicolas CHARLES
  • Target version changed from 2.6.20 to 2.10.10

Nico, I think it isn't the case anymore in 2.10 (or 2.11 ?), can you confirm ?

#10 Updated by Nicolas CHARLES almost 4 years ago

  • Status changed from New to 8

Oh, the rudder_rm is indeed relevant !
we are never removing the old inventory on windows

#11 Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.10.10 to 2.10.11

#12 Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.10.11 to 2.10.12

#13 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.12 to 2.10.13

#14 Updated by Benoît PECCATTE over 3 years ago

  • Status changed from 8 to New

#15 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.13 to 2.10.14

#16 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.14 to 2.10.15

#17 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.15 to 2.10.16

#18 Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 2.10.16 to 2.10.17

#19 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.10.17 to 2.10.18

#20 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.10.18 to 2.10.19

#21 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.10.19 to 2.10.20

#22 Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 2.10.20 to 2.11.18

#23 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.11.18 to 2.11.19

#24 Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 2.11.19 to 2.11.20

#25 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.20 to 2.11.21

#26 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.21 to 2.11.22

#27 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.22 to 2.11.23

#28 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.23 to 2.11.24

#29 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.24 to 308

#30 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 308 to 3.1.14

#31 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.14 to 3.1.15

#32 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.15 to 3.1.16

#33 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.16 to 3.1.17

#34 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.17 to 3.1.18

#35 Updated by Nicolas CHARLES almost 2 years ago

ha, but del is not a command on Windows, so that's why it's more complex than that
we used to use transformer for that, but it was because of limitations, we could simply delete files now

#36 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 3.1.18 to 3.1.19

#37 Updated by Alexis MOUSSET almost 2 years ago

  • Is duplicate of Bug #6550: On windows node inventory files are not deleted added

#38 Updated by Alexis MOUSSET almost 2 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF