Project

General

Profile

Actions

Bug #4584

closed

Building node configuration in the promise generation process takes a lot of time

Added by François ARMAND over 10 years ago. Updated almost 10 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Performance and scalability
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Name check:
Fix check:
Regression:

Description

Now that some major performance update were done (for ex. in #4242) in the promise generation process, the new bottleneck seems to be the node configuration generation.

It seems that in that process, the DeploymentService_buildNodeConfigurations#replaceNodeVars is taking ~90% of total time of that subtask.

So, it seems that we are doing something very wrong in the way we process ${rudder.XXX} parameters.


Related issues 3 (0 open3 closed)

Related to Rudder - Bug #4242: Promise generation takes too long when getting more and more nodesReleasedFrançois ARMAND2014-03-11Actions
Related to Rudder - Architecture #4585: Remove Rule-dependant parameters like ${rudder.common.target.nodeid}Rejected2014-03-11Actions
Has duplicate Rudder - Architecture #4778: Optimize promise generation algorithm: Rudder variables lookupReleasedFrançois ARMAND2014-04-29Actions
Actions

Also available in: Atom PDF