Project

General

Profile

Actions

Bug #4614

closed

A deleted group on a Rudder server A is still there on a Rudder server B after a synchronization of /var/rudder/configuration-repository

Added by Nicolas PERRON over 10 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
System integration
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
Fix check:
Regression:

Description

On a Rudder server A, a group is deleted but after a synchronization of the folder /var/rudder/configuration-repository (by git push) on a Rudder server B, the group is still present. The synchronization of the repository is followed by a post-hook which trigger a "restore archive".

Nevertheless, on the /var/rudder/configuration-repository, the XML file associated to the deleted group is present although Rudder should remove it and commit the change. The git log show only commits of archive.
I suppose a bug permitted to erase the group from the LDAP and not into the git.

Actions #1

Updated by Benoît PECCATTE about 9 years ago

  • Category set to System integration
  • Target version set to 2.10.14
Actions #2

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.14 to 2.10.15
Actions #3

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.15 to 2.10.16
Actions #4

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.16 to 2.10.17
Actions #5

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.17 to 2.10.18
Actions #6

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.18 to 2.10.19
Actions #7

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.19 to 2.10.20
Actions #8

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.20 to 2.11.18
Actions #9

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #10

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #11

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #12

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #13

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #14

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #15

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.24 to 308
Actions #16

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 308 to 3.1.14
Actions #17

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #18

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #19

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #20

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #21

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #22

Updated by François ARMAND about 7 years ago

  • Status changed from New to Rejected
  • Priority set to 0

I'm closing that ticket because it is about a non supported synchronization scheme and lacks a lot of thing to be able to analysis it further (basically, if the group is /var/rudder/configuration-repository, it is normal that the archive restaure does not delete it).

Even if the problem is "deleting a group does not correctly delete the corresponding xml file in /var/rudder/configuration-repository", the problem is either not here anymore (works as expected in 3.1.x) or the steps to reproduce it are not present.

Actions

Also available in: Atom PDF