Project

General

Profile

Actions

Bug #4880

closed

The use of escaped string into class_parameter lead to "Unknown state" reports

Added by Nicolas PERRON over 8 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

Using bundle with parameters containing escaped string lead to "Unknown state" reports. The reason is that Rudder will expect a string with escapement but the returned reports will be an escaped string. Here an exemple:

On server side (techniques/ncf_techniques/test_commands/0.1/expected_reports.csv):

# This file contains one line per report expected by Rudder from this technique
# Format: technique_name;;class_prefix_${key};;@@RUDDER_ID@@;;component name;;component key
test_commands;;command_execution_module_/bin/echo \"Good job\";;@@RUDDER_ID@@;;Command execution;;/bin/echo \"Good job\" 
test_commands;;command_execution_module_/tmp/module_test;;@@RUDDER_ID@@;;Command execution module;;/tmp/module_test

On node side (/var/rudder/cfengine-community/inputs/rudder_expected_reports.csv.res) :

# This file contains one line per report expected by Rudder from this technique
# Format: technique_name;;class_prefix_${key};;@@RUDDER_ID@@;;component name;;component key
test_commands;;command_execution_module__bin_echo__Good_job_;;fc28d3ea-0331-4610-84e4-c9858a561489@@656cf7af-2991-4fb8-abbe-8959baf471c2@@47;;Command execution;;/bin/echo "Good job" 
test_commands;;command_execution_module__tmp_module_test;;fc28d3ea-0331-4610-84e4-c9858a561489@@656cf7af-2991-4fb8-abbe-8959baf471c2@@47;;Command execution module;;/tmp/module_test

The result is in the attached screenshot.

The problem seems to be into the 30_generic_methods/logger_rudder.cf


Files

Strange_Expecting_reports.png (98.2 KB) Strange_Expecting_reports.png Nicolas PERRON, 2014-05-22 12:09

Related issues 1 (1 open0 closed)

Related to Rudder - User story #4873: Add bundle command_execution_module() to execute CFEngine modulesNewActions
Actions #1

Updated by Nicolas PERRON over 8 years ago

The issue has been spotted from #4873

Actions #2

Updated by Alexis Mousset about 6 years ago

  • Category set to Generic methods
Actions #3

Updated by Benoît PECCATTE over 5 years ago

  • Status changed from New to Rejected
  • Priority set to 0

This doesn't happen anymore

Actions #4

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
Actions #5

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category changed from Generic methods to Generic methods
Actions

Also available in: Atom PDF