Project

General

Profile

Actions

Bug #5304

closed

Cannot archive everything because /var/rudder/configuration-repository/groups does not exist

Added by Nicolas CHARLES over 8 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
N/A
Category:
Web - Maintenance
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Regression:

Description

We tried to archive everything, but it failed because folder group was not there

Indeed, it was removed from the FS (git status showed it was not there). No idea why. recreating this folder solved the issue


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #5509: No groups directory in /var/rudder/configuration-repositoryReleasedNicolas CHARLES2014-09-10Actions
Actions #1

Updated by Nicolas CHARLES over 8 years ago

It happened twice today, and we didn't remove it for sure !
We did commit some techniques during the day

Actions #2

Updated by Nicolas PERRON over 8 years ago

  • Target version changed from 2.10.4 to 2.6.18
Actions #3

Updated by Nicolas PERRON over 8 years ago

  • Target version changed from 2.6.18 to 2.10.5
Actions #4

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.5 to 2.10.6
Actions #5

Updated by Vincent MEMBRÉ about 8 years ago

  • Assignee set to Jonathan CLARKE
Actions #6

Updated by François ARMAND about 8 years ago

  • Assignee changed from Jonathan CLARKE to François ARMAND
Actions #7

Updated by Matthieu CERDA about 8 years ago

  • Target version changed from 2.10.6 to 2.10.7
Actions #8

Updated by Nicolas CHARLES about 8 years ago

Ok, I was able to reproduce this one on orchestrateur-2 by simply removing a group
Webapp logs don't show anything

Git log say

commit cf9d2d392669e372e477533bf79c308001c79806
Author: jon.doe <email not set>
Date:   Sun Oct 5 13:34:26 2014 +0200

    Delete archive of node group with ID '55956cbc-8514-401b-bc4d-1f2f7a74f8d1'

commit fe20065a77fb856b8ee92578f4e603910aa2b930
Author: jon.doe <email not set>
Date:   Sun Oct 5 13:34:25 2014 +0200

    Archive rule with ID '75f6b55f-fe11-418b-8199-64a00e3bf911'

and then the commit says:

 git show cf9d2d392669e372e477533bf79c308001c79806
commit cf9d2d392669e372e477533bf79c308001c79806
Author: jon.doe <email not set>
Date:   Sun Oct 5 13:34:26 2014 +0200

    Delete archive of node group with ID '55956cbc-8514-401b-bc4d-1f2f7a74f8d1'

diff --git a/groups/55956cbc-8514-401b-bc4d-1f2f7a74f8d1.xml b/groups/55956cbc-8514-401b-bc4d-1f2f7a74f8d1.xml
deleted file mode 100644
index b81106c..0000000
--- a/groups/55956cbc-8514-401b-bc4d-1f2f7a74f8d1.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<nodeGroup fileFormat="5">
-  <id>55956cbc-8514-401b-bc4d-1f2f7a74f8d1</id>
-  <displayName>All fast debian</displayName>
-  <description></description>
-  <query>
-    {&quot;select&quot;:&quot;node&quot;,&quot;composition&quot;:&quot;And&quot;,&quot;where&quot;:[{&quot;objectType&quot;:&quot;node&quot;,&quot;attribute&quot;:&quot;OS&quot;,&quot;comparator&quot;:&quot;eq&quot;,&quot;value&quot;:&q
-  </query>
-  <isDynamic>true</isDynamic>
-  <nodeIds/>
-  <isEnabled>true</isEnabled>
-  <isSystem>false</isSystem>
-</nodeGroup>
\ No newline at end of file

I guess it's a bit eager when removing the group

Actions #9

Updated by Jonathan CLARKE about 8 years ago

Maybe the directory ends up empty and therefore is removed by git? (git doesn't store empty directories)

Actions #10

Updated by François ARMAND about 8 years ago

  • Status changed from New to Rejected

The reason of the missing "groups" directory is cleary #5509 which was removing it during the save process.

Without it, the "groups" directory is correctly created, even if missing before the save.

So I marked that one as "duplicate" of #5509

Actions

Also available in: Atom PDF