Project

General

Profile

Actions

Bug #5368

closed

SLES init script strangeness

Added by Florian Heigl over 9 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
2
Assignee:
-
Category:
System integration
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
Fix check:
Regression:

Description

Hi,

on the following OS I see a funny behaviour:
rudders1:/var/log # cat /etc/SuSE-release
SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 3

rudders1:/var/log # chkconfig rudder-slapd on
insserv: Service syslog is missed in the runlevels 4 to use service rudder-slapd

Syslog isn't installed since I added this package:
rudders1:/var/log # rpm -aq | grep -i rsyslog
rsyslog-module-pgsql-5.10.1-0.7.49
rsyslog-5.10.1-0.7.49

It seems the system used the original SLES rsyslog package.

Package is installed:
rudders1:/var/log # chkconfig --list | grep -e syslog -e rudder
earlysyslog 0:off 1:off 2:on 3:on 4:off 5:on 6:off
rudder-agent 0:off 1:off 2:off 3:off 4:off 5:off 6:off
rudder-jetty 0:off 1:off 2:off 3:off 4:off 5:off 6:off
rudder-server-root 0:off 1:off 2:off 3:off 4:off 5:off 6:off
rudder-slapd 0:off 1:off 2:on 3:on 4:on 5:on 6:off
syslog 0:off 1:off 2:on 3:on 4:off 5:on 6:off

My only guess is the following:
rudder-slapd:
  1. Required-Start: $remote_fs $syslog
  2. Required-Stop: $remote_fs $syslog
vs.
syslog:
  1. Provides: syslog
  2. Required-Start:
  3. Should-Start: earlysyslog network
  4. Required-Stop:

I'm no linux init guru, but is it because of the $syslog vs. syslog difference?

Actions #1

Updated by Matthieu CERDA over 9 years ago

  • Status changed from New to Discussion
  • Assignee set to Matthieu CERDA
  • Priority changed from N/A to 2
  • Target version set to 2.10.4

Hello Florian!

Indeed, it seems the rudder-slapd init script tries to enable itself in the runlevel 4 in case of a chkconfig,

The $syslog/syslog is a LSB standard and should be no problem. (http://refspecs.linuxfoundation.org/LSB_3.1.0/LSB-Core-generic/LSB-Core-generic/facilname.html)

Can you please tell me if the failure is definitive or if the script is activated anyway ? I can't reproduce this yet on a SLES 11 SP1, I'm trying to find a SLES 11 SP3 iso now :)

Actions #2

Updated by Florian Heigl over 9 years ago

Hi,

the script is activated anyway.

See line here:
rudder-slapd 0:off 1:off 2:on 3:on 4:on 5:on 6:off

Startup is OK.

Download url:

https://susestudio.com/a/G8ZLPr/florian-s-sles-11-sp3-jeos-rudder-server

Actions #3

Updated by Nicolas PERRON over 9 years ago

  • Target version changed from 2.10.4 to 2.10.5
Actions #4

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.5 to 2.10.6
Actions #5

Updated by Matthieu CERDA over 9 years ago

  • Target version changed from 2.10.6 to 2.10.7
Actions #6

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.7 to 2.10.8
Actions #7

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.8 to 2.10.9
Actions #8

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.9 to 2.10.10
Actions #9

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.10 to 2.10.11
Actions #10

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.11 to 2.10.12
Actions #11

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.12 to 2.10.13
Actions #12

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.13 to 2.10.14
Actions #13

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.14 to 2.10.15
Actions #14

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.15 to 2.10.16
Actions #15

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.16 to 2.10.17
Actions #16

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.17 to 2.10.18
Actions #17

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.18 to 2.10.19
Actions #18

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.19 to 2.10.20
Actions #19

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.20 to 277
Actions #20

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 277 to 2.11.18
Actions #21

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #22

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #23

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #24

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #25

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #26

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #27

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.24 to 308
Actions #28

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 308 to 3.1.14
Actions #29

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #30

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #31

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #32

Updated by Benoît PECCATTE over 7 years ago

  • Assignee deleted (Matthieu CERDA)
Actions #33

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #34

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #35

Updated by François ARMAND about 7 years ago

  • Status changed from Discussion to Rejected
  • Priority set to 0

This does not seem to be the case anymore with Rudder 3.1.18 and up. Please, fill free to reopen the ticket if it happens again.

Actions

Also available in: Atom PDF