Project

General

Profile

Actions

Bug #5418

closed

Bug #5402: Agent can't run because some ncf promises are CFEngine 3.6 specific

The script list-compatible-inputs may not be yet available at the start of the Web Interface, and thus first promise generation fails

Added by Nicolas CHARLES about 8 years ago. Updated almost 8 years ago.

Status:
Released
Priority:
1
Category:
System integration
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Regression:

Description

Packaging this file in Rudder solved the dependency issue, however it does still not enforce that the file is present in the /var/rudder/tools folder at first promise generation.

Since we constantly have permissions/availability of file issue, we could greatly benefit from having the bundle "update_action" run at the end of the init script (like for other password bundles)


Subtasks 1 (0 open1 closed)

Bug #5420: tools are not copied when runngin rudder-init.sh making first promises generation impossibleReleasedNicolas CHARLES2014-08-25Actions
Actions #1

Updated by Nicolas CHARLES about 8 years ago

  • Status changed from New to Pending technical review
  • Assignee changed from Nicolas CHARLES to Benoît PECCATTE
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/465
Actions #2

Updated by Nicolas CHARLES about 8 years ago

  • Status changed from Pending technical review to Pending release
  • % Done changed from 0 to 100

Applied in changeset packages:commit:65a43978b17e64716ae56b11759f33acf62556b0.

Actions #3

Updated by Matthieu CERDA about 8 years ago

Applied in changeset packages:commit:8b0760ffe77e57704ed842812f348e0291de5f1f.

Actions #4

Updated by Vincent MEMBRÉ almost 8 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 2.10.5, which was released on the 28/08/2014.

Actions

Also available in: Atom PDF