Project

General

Profile

Actions

Bug #5432

closed

Deleted Technique from technique editor are still present in directive tree view

Added by John Robert Mendoza almost 10 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
3
Assignee:
-
Category:
Web - Technique editor
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Medium
Priority:
0
Name check:
Fix check:
Regression:

Description

The reference technique library page doesn't get updated and still shows the custom technique I've deleted from ncf editor. Here's how to reproduce the bug.

1. Create a new technique using the ncf technique editor
2. Check the technique library management page and the newly created technique will be shown under the "Meta Technique" section of the Reference Technique Library tree.
3. Head back to the technique editor and delete your custom technique.
4. Refresh the library management page. Observe that the custom technique is still displayed.


Related issues 4 (0 open4 closed)

Has duplicate Rudder - Bug #5829: Deleted Technique from NCF builder are still present in Rudder Technique libraryRejectedActions
Has duplicate Rudder - Bug #7202: Technique Editor and Rudder Techniques Library isn't coherentRejectedActions
Has duplicate Rudder - Bug #13813: User's technique don't disapear after deletingRejectedVincent MEMBRÉActions
Has duplicate Rudder - Bug #6641: When we remove a technique from the editor, it is still available for new directive creationRejectedActions
Actions #1

Updated by John Robert Mendoza almost 10 years ago

Forgot to mention the target version for this. It's 2.11.2-release-1

Actions #2

Updated by Vincent MEMBRÉ almost 10 years ago

  • Assignee set to Vincent MEMBRÉ
  • Target version set to 2.11.3

Thank you for reporting John.

In fact the technique is not automatically deleted from Rudder. I will add a way to automate this.

for now, you can manually delete the technique:

cd /var/rudder/configuration-repository
# A 'git status' would show that cfengine files were deleted, but it was not commited, so rm the files
git rm -r ncf/50_techniques/my_technique techniques/ncf_techniques/my_technique
git commit -m "delete my_technique" 
# Reload technique library
curl -s -f -k "https://localhost/rudder/api/techniqueLibrary/reload" 

I will add ncf-hooks that delete the files automatically. and reload Rudder technique library

Actions #3

Updated by Vincent MEMBRÉ almost 10 years ago

Before running those commands, please delete all Directive that were created based on that Technique

Actions #4

Updated by Matthieu CERDA over 9 years ago

  • Target version changed from 2.11.3 to 2.11.4
Actions #5

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.11.4 to 2.11.5
Actions #6

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.11.5 to 2.11.6
Actions #7

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.11.6 to 2.11.7
Actions #8

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.11.7 to 2.11.8
Actions #9

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.11.8 to 2.11.9
Actions #10

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.11.9 to 2.11.10
Actions #11

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.11.10 to 2.11.11
Actions #12

Updated by Benoît PECCATTE about 9 years ago

  • Category set to Web - Technique editor
Actions #13

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.11.11 to 2.11.12
Actions #14

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.11.12 to 2.11.13
Actions #15

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.11.13 to 2.11.14
Actions #16

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.14 to 2.11.15
Actions #17

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.15 to 2.11.16
Actions #18

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.16 to 2.11.17
Actions #19

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.17 to 2.11.18
Actions #20

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #21

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #22

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #23

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #24

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #25

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #26

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.24 to 308
Actions #27

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 308 to 3.1.14
Actions #28

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #29

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #30

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #31

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #32

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #33

Updated by François ARMAND about 7 years ago

  • User visibility set to Getting started - demo | first install | level 1 Techniques
  • Effort required set to Small
  • Priority set to 0

This is still happening.
When a directive created from the deleted technique is configured on a node, running "rudder agent run" leads to:

Rudder agent 3.1.19.rc1.git201704040733 (CFEngine Core 3.6.5)
Node uuid: root
2017-04-04T12:04:20+0200    error: Bundle 'vim_install' listed in the bundlesequence is not a defined bundle
2017-04-04T12:04:20+0200    error: Fatal CFEngine error: Errors in promise bundles: could not verify bundlesequence
error    Rudder agent was interrupted during execution by a fatal error
         Run with -i to see log messages.

## Summary #####################################################################
error:        1
execution time: 0.65s
################################################################################

But nothing in the UI let you thing that there a problem (no error in generation, after delete, etc). And you can even create again new directive from the deleted technique, without any error!
Moreover, the compliance is only in "no answer", so we need to go the node to understand the problem.

You have to delete all directives from that technique by hand to make rudder agent works again.

Actions #34

Updated by François ARMAND about 7 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround

I'm setting the severity to major, because of the potential silent breaking of all nodes with the directive, and a not so easy diagnosis for the problem.

Actions #35

Updated by François ARMAND about 7 years ago

  • Has duplicate Bug #5829: Deleted Technique from NCF builder are still present in Rudder Technique library added
Actions #36

Updated by François ARMAND about 7 years ago

  • Subject changed from Reference Technique Library Tree after deleting custom NCF directive to Deleted Technique from NCF builder are still present in Rudder Technique library
Actions #37

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
Actions #38

Updated by Jonathan CLARKE about 7 years ago

  • Assignee deleted (Vincent MEMBRÉ)
Actions #39

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.20 to 3.1.21
Actions #40

Updated by François ARMAND about 7 years ago

  • Severity changed from Major - prevents use of part of Rudder | no simple workaround to Minor - inconvenience | misleading | easy workaround
  • Priority changed from 0 to 36

This must be tested again. In 4.1, it seems that the directive is disabled (or at least not accessible in the UI) when the ncf technique is deleted, and so the policy generation is not broken. (and so, Minor in place of major).

In all cases, we must add some warning regarding the usage of the technique before deleting it.

Actions #41

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.21 to 3.1.22
Actions #42

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 36 to 45
Actions #43

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.22 to 3.1.23
Actions #44

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.23 to 3.1.24
Actions #45

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.24 to 3.1.25
  • Priority changed from 45 to 46
Actions #46

Updated by Benoît PECCATTE over 6 years ago

  • Priority changed from 46 to 56
Actions #47

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.25 to 387
  • Priority changed from 56 to 57
Actions #48

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 387 to 4.1.10
Actions #49

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.10 to 4.1.11
  • Priority changed from 57 to 58
Actions #50

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
  • Priority changed from 58 to 59
Actions #51

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
Actions #52

Updated by Vincent MEMBRÉ almost 6 years ago

  • Effort required changed from Small to Medium
  • Priority changed from 59 to 31
Actions #53

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
Actions #54

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
Actions #55

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.15 to 4.1.16
Actions #56

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
  • Priority changed from 31 to 32
Actions #57

Updated by François ARMAND over 5 years ago

  • Has duplicate Bug #7202: Technique Editor and Rudder Techniques Library isn't coherent added
Actions #58

Updated by François ARMAND over 5 years ago

  • Has duplicate Bug #13813: User's technique don't disapear after deleting added
Actions #59

Updated by François ARMAND over 5 years ago

  • Subject changed from Deleted Technique from NCF builder are still present in Rudder Technique library to Deleted Technique from technique editor are still present in directive tree view
  • Priority changed from 32 to 0
Actions #60

Updated by François ARMAND over 5 years ago

  • Related to Bug #6641: When we remove a technique from the editor, it is still available for new directive creation added
Actions #61

Updated by François ARMAND over 5 years ago

  • Related to deleted (Bug #6641: When we remove a technique from the editor, it is still available for new directive creation)
Actions #62

Updated by François ARMAND over 5 years ago

  • Has duplicate Bug #6641: When we remove a technique from the editor, it is still available for new directive creation added
Actions #63

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.17 to 4.1.18
Actions #64

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.18 to 4.1.19
Actions #65

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #66

Updated by Alexis Mousset almost 5 years ago

  • Target version changed from 4.1.20 to 588
Actions #67

Updated by Alexis Mousset almost 5 years ago

  • Target version changed from 588 to 5.0.13
Actions #68

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #69

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #70

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #71

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #72

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #73

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #74

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #75

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #76

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #77

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #78

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #79

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #80

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #81

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #82

Updated by François ARMAND over 2 years ago

  • Status changed from New to Resolved

As of 7.0 at least, it is not the case anymore.

Actions

Also available in: Atom PDF