Project

General

Profile

Actions

Bug #5555

closed

logger_rudder doesn't properly canonify entries

Added by Nicolas CHARLES about 8 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
1
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

in logger_rudder, we use a complex shell script to canonify the key_value
However it does not canonify as CFEngine does:
"foo\cfoo" is canonified by CFEngine as "foo__foo" but the script canonify it as "foo_foo"
"foo\'foo" is canonified by CFEngine as "foo_foo" and the script canonify it as "foo_foo"

The second is by mer chance, it is only the the script drops the \


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #5598: logger_rudder fails on windowsReleasedJonathan CLARKEActions
Actions #1

Updated by Benoît PECCATTE almost 8 years ago

  • Status changed from New to Rejected

Duplicates #5598

Actions #2

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #3

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category set to Generic methods
Actions

Also available in: Atom PDF