Project

General

Profile

Bug #5642

Bug #5609: It's not possible to update package to latest version

Update package to latest version (branch 2.10)

Added by Nicolas CHARLES over 5 years ago. Updated over 5 years ago.

Status:
Released
Priority:
N/A
Category:
Techniques
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

In #5609, we created a new version of technique rpmPackageInstallation
We need to apply the good practices of 2.10 in it for it to work nicely (namely, use ${paths} for paths, and use rpmvercmp)

#1

Updated by Nicolas CHARLES over 5 years ago

  • Status changed from 8 to Pending technical review
  • Assignee changed from Nicolas CHARLES to Benoît PECCATTE
  • Pull Request set to https://github.com/Normation/rudder-techniques/pull/536
#2

Updated by Nicolas CHARLES over 5 years ago

  • Status changed from Pending technical review to Pending release
  • % Done changed from 0 to 100

Applied in changeset policy-templates:commit:df36267a95a8a26f952fde98a214a1815f8a5827.

#3

Updated by Benoît PECCATTE over 5 years ago

Applied in changeset policy-templates:commit:d71d338f86e7a846f4dfc70f148f5bbdb39b5793.

#4

Updated by Vincent MEMBRÉ over 5 years ago

  • Parent task set to #5609
#5

Updated by Vincent MEMBRÉ over 5 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 2.10.7 and 2.11.4, which were released today.

Also available in: Atom PDF