Project

General

Profile

Actions

Bug #5720

closed

Directive fields validation is done even on unused (by configuration) fields (like edition types in file content technique)

Added by Florian Heigl over 9 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
2
Assignee:
-
Category:
Techniques
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Medium
Priority:
0
Name check:
Fix check:
Regression:

Description

Hi,

screenshot attached.


Files

editfile_ver6_zones.jpg (123 KB) editfile_ver6_zones.jpg Florian Heigl, 2014-11-02 22:57
Actions #1

Updated by Florian Heigl over 9 years ago

Florian Heigl wrote:

Hi,

screenshot attached.

now inline, I hope:

Actions #2

Updated by François ARMAND over 9 years ago

  • Category set to Techniques
  • Assignee set to Nicolas CHARLES
  • Priority changed from N/A to 2

Nico, could you look at that please ?

Thanks :)

Actions #3

Updated by Nicolas CHARLES over 9 years ago

  • Status changed from New to Discussion
  • Assignee changed from Nicolas CHARLES to Florian Heigl

LForian,

We don't have yet the possibility to have dependant fields. So its a bit of all or nothing, and we often stay on the safe side by defining some values to be mandatory
But in this case, we have default values; in this case the default is ### Beginning of section managed by Rudder, and is not used if the tick is not ticked

is it really an issue for you ?

Actions #4

Updated by Benoît PECCATTE over 9 years ago

  • Project changed from 24 to Rudder
  • Category changed from Techniques to Techniques
Actions #5

Updated by Benoît PECCATTE about 8 years ago

  • Target version set to 2.11.21
Actions #6

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #7

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #8

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #9

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.24 to 308
Actions #10

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 308 to 3.1.14
Actions #11

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #12

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #13

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #14

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #15

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #16

Updated by François ARMAND about 7 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Getting started - demo | first install | level 1 Techniques
  • Priority set to 0
Actions #17

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
Actions #18

Updated by Jonathan CLARKE about 7 years ago

  • Status changed from Discussion to New
Actions #19

Updated by Jonathan CLARKE about 7 years ago

  • Assignee deleted (Florian Heigl)
Actions #20

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.20 to 3.1.21
Actions #21

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.21 to 3.1.22
Actions #22

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 0 to 29
Actions #23

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 29 to 42
Actions #24

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.22 to 3.1.23
Actions #25

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.23 to 3.1.24
Actions #26

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.24 to 3.1.25
Actions #27

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.25 to 387
  • Priority changed from 42 to 43
Actions #28

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 387 to 4.1.10
Actions #29

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.10 to 4.1.11
Actions #30

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
  • Priority changed from 43 to 44
Actions #31

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
Actions #32

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
  • Priority changed from 44 to 45
Actions #33

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
Actions #34

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.15 to 4.1.16
  • Priority changed from 45 to 46
Actions #35

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
Actions #36

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.17 to 4.1.18
  • Priority changed from 46 to 0
Actions #37

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.18 to 4.1.19
Actions #38

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #39

Updated by Alexis Mousset almost 5 years ago

  • Target version changed from 4.1.20 to 588
Actions #40

Updated by Alexis Mousset almost 5 years ago

  • Target version changed from 588 to 5.0.13
Actions #41

Updated by Alexis Mousset almost 5 years ago

  • Subject changed from Enforce a file content (v: 6.0) wants "zone" to be specified if not selected to Directive fields validation is done even on usunsed (by configuration) fields (like edition types in file content technique)
Actions #42

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #43

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #44

Updated by Benoît PECCATTE over 4 years ago

  • Subject changed from Directive fields validation is done even on usunsed (by configuration) fields (like edition types in file content technique) to Directive fields validation is done even on unused (by configuration) fields (like edition types in file content technique)
  • Effort required set to Medium
Actions #45

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #46

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #47

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #48

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #49

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #50

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #51

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #52

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #53

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #54

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #55

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #56

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #57

Updated by François ARMAND over 2 years ago

  • Status changed from New to Resolved

Since then, we made mandatory & optionnal fields more consistant. At least on the depicted case, there is no error anymore.

I'm closing it and we will open new ticket to track new specific occurences.

Actions

Also available in: Atom PDF