Project

General

Profile

Actions

Bug #6074

closed

When we have space in classes condition, the technique is no longer displayed in the Tehcnique editor, and we cannot update anymore any techniques

Added by Nicolas CHARLES over 7 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
1
Category:
Web - Technique editor
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

If I insert a blank space in the class condition in the technique editor, the generated cfengine code is invalid, and the technique is no longer accessible. When we click on it, it stays blank, and fails to display anything

Logs say

[Sun Jan 04 12:36:44 2015] [error] ERROR: Exception triggered, Unable to parse file /var/rudder/configuration-repository/ncf/50_techniques/technique/technique.cf
[Sun Jan 04 12:36:44 2015] [error] Command '['cf-promises', '-pjson', '-f', u'/var/rudder/configuration-repository/ncf/50_techniques/technique/technique.cf']' returned non-zero exit status 1
<pre>

<pre>
#cf-promises -f /var/rudder/configuration-repository/ncf/50_techniques/technique/technique.cf
/var/rudder/configuration-repository/ncf/50_techniques/technique/technique.cf:24:72: error: Syntax error in context string
      ifvarclass => "linux.directory_check_exists__root_technique_kept. file_check_exists__etc_technique_conf_error";
                                                                       ^
2015-01-05T16:42:59+0100    error: There are syntax errors in policy files
</pre>

Removing the space solves the issue


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #8763: When the conditions contain spaces, they are kept and the generated file is invalidReleasedVincent MEMBRÉActions
Actions #1

Updated by Alexis Mousset about 6 years ago

  • Category set to Technique editor - API
Actions #2

Updated by Alexis Mousset about 6 years ago

  • Is duplicate of Bug #8763: When the conditions contain spaces, they are kept and the generated file is invalid added
Actions #3

Updated by Alexis Mousset about 6 years ago

  • Status changed from New to Rejected
Actions #4

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #5

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category changed from Technique editor - API to Web - Technique editor
Actions

Also available in: Atom PDF