Project

General

Profile

Actions

Bug #6191

closed

Allow to migrate or delete Directive based on a missing Technique

Added by Vincent MEMBRÉ over 9 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
1
Assignee:
-
Category:
Web - Config management
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
43
Name check:
Fix check:
Regression:

Description

Acutally there is a big error when you want to edit a Direct based on a deleted Technique.

We shoudl allow to Delet/Migrate them, and disable those Directives when meet them (so policy generation can continue)


Related issues 2 (0 open2 closed)

Related to Rudder - User story #5670: Auto add ncf Technique to Rudder techniquesReleasedFrançois ARMAND2014-11-24Actions
Is duplicate of Rudder - Bug #5203: There is no way to remove a Directive based on a Technique that no longer existsReleasedVincent MEMBRÉActions
Actions #1

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.9 to 2.10.10
Actions #2

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.10 to 2.10.11
Actions #3

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.11 to 2.10.12
Actions #4

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.12 to 2.10.13
Actions #5

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.13 to 2.10.14
Actions #6

Updated by François ARMAND about 9 years ago

  • Related to User story #5670: Auto add ncf Technique to Rudder techniques added
Actions #7

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.14 to 2.10.15
Actions #8

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.15 to 2.10.16
Actions #9

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.16 to 2.10.17
Actions #10

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.17 to 2.10.18
Actions #11

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.18 to 2.10.19
Actions #12

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.19 to 2.10.20
Actions #13

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.20 to 277
Actions #14

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 277 to 2.11.18
Actions #15

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #16

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #17

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #18

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #19

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #20

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #21

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.24 to 308
Actions #22

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 308 to 3.1.14
Actions #23

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #24

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #25

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #26

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #27

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #28

Updated by Jonathan CLARKE over 7 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
Actions #29

Updated by Benoît PECCATTE about 7 years ago

  • Priority set to 30
Actions #30

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
Actions #31

Updated by Jonathan CLARKE about 7 years ago

  • Assignee deleted (Vincent MEMBRÉ)
Actions #32

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.20 to 3.1.21
Actions #33

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.21 to 3.1.22
Actions #34

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 30 to 43
Actions #35

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.22 to 3.1.23
Actions #36

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.23 to 3.1.24
Actions #37

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.24 to 3.1.25
Actions #38

Updated by François ARMAND over 6 years ago

  • Related to Bug #5203: There is no way to remove a Directive based on a Technique that no longer exists added
Actions #39

Updated by François ARMAND over 6 years ago

  • Related to deleted (Bug #5203: There is no way to remove a Directive based on a Technique that no longer exists)
Actions #40

Updated by François ARMAND over 6 years ago

  • Is duplicate of Bug #5203: There is no way to remove a Directive based on a Technique that no longer exists added
Actions #41

Updated by François ARMAND over 6 years ago

  • Status changed from New to Rejected

Duplicates #5203

Actions

Also available in: Atom PDF