Project

General

Profile

Actions

Bug #6215

closed

Bug #5741: Upgrading rudder-inventory-ldap between two major OS versions makes slapd unable to operate because of BerkeleyDB (backport)

rudder-inventory-ldap fails to build on old Debian OSes

Added by Matthieu CERDA over 6 years ago. Updated over 6 years ago.

Status:
Released
Priority:
1
Category:
System integration
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

On old Debians (less than wheezy), the rudder-inventory-ldap compilation fails on:

19:05:33 checking db.h presence... no
19:05:33 configure: WARNING: db.h: accepted by the compiler, rejected by the preprocessor!
19:05:33 configure: WARNING: db.h: proceeding with the compiler's result
19:05:33 checking for db.h... yes
19:05:33 checking for Berkeley DB major version in db.h... conftest.c:128:16: error: db.h: No such file or directory
19:05:33 1
19:05:33 checking for Berkeley DB minor version in db.h... conftest.c:128:16: error: db.h: No such file or directory
19:05:33 0
19:05:33 checking if Berkeley DB version supported by BDB/HDB backends... no
19:05:33 configure: error: BerkeleyDB version incompatible with BDB/HDB backends
19:05:33 make[1]: *** [configure-stamp] Error 1

It seems it is just because ./configure fails to detect db.h whereas it exists... if I force it to acknowledge "everything is all right", the package builds successfuly...

(The attached patch shows the override I used).

I don't know how can we solve this...

Help ! :)


Files

openldap-override-old-debian.patch (1.12 KB) openldap-override-old-debian.patch Matthieu CERDA, 2015-01-31 00:59
Actions #2

Updated by Matthieu CERDA over 6 years ago

  • Status changed from Discussion to Pending technical review
  • Assignee set to Benoît PECCATTE
  • % Done changed from 0 to 100
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/612
Actions #3

Updated by Matthieu CERDA over 6 years ago

PR updated with a cleaner approach :)

Actions #4

Updated by Matthieu CERDA over 6 years ago

  • Status changed from Pending technical review to Pending release

Applied in changeset packages:rudder-packages|commit:9cedd33472718eaced5f8b3d508353eaa7fe6a99.

Actions #5

Updated by Jonathan CLARKE over 6 years ago

Applied in changeset packages:rudder-packages|commit:1bdb9e21e92744e33ea3068830bcc777ee2d7184.

Actions #6

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.10.10 to 2.10.9
Actions #7

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.10.9 to 2.10.10
Actions #8

Updated by Vincent MEMBRÉ over 6 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 2.10.10 and 2.11.7, which were these days.

Actions

Also available in: Atom PDF