Project

General

Profile

Actions

Bug #6225

closed

keyNotFound in SectionVal - programming error

Added by François ARMAND over 7 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
1
Category:
Web - Config management
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Regression:

Description

In some case, we can get the awful:

java.util.NoSuchElementException: key not found: PKG_MGR_APPLICABLE_OS
at scala.collection.MapLike$class.default(MapLike.scala:228) ~[scala-library-2.10.3.jar:na]
at scala.collection.AbstractMap.default(Map.scala:58) ~[scala-library-2.10.3.jar:na]
at scala.collection.MapLike$class.apply(MapLike.scala:141) ~[scala-library-2.10.3.jar:na]
at scala.collection.AbstractMap.apply(Map.scala:58) ~[scala-library-2.10.3.jar:na]
at com.normation.rudder.domain.policies.SectionVal$$anonfun$8$$anonfun$apply$2.apply(Directive.scala:193) ~[rudder-core-2.10.9-SNAPSHOT.jar:na]
at com.normation.rudder.domain.policies.SectionVal$$anonfun$8$$anonfun$apply$2.apply(Directive.scala:193) ~[rudder-core-2.10.9-SNAPSHOT.jar:na]
Actions #1

Updated by François ARMAND over 7 years ago

It was on our orchestrateur but I can't reproduce it anymore... It was happening when archiving the directive lib.

Actions #2

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.10.10 to 2.10.11
Actions #3

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.10.11 to 2.10.12
Actions #4

Updated by François ARMAND over 7 years ago

  • Status changed from In progress to Rejected
  • Reproduced set to No

I was not able to reproduce it anymore at all. Closing it.

Actions

Also available in: Atom PDF