Project

General

Profile

Actions

Bug #6243

closed

Install rudder-agent on minimal centos5 fails

Added by Vincent MEMBRÉ over 9 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
System integration
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
30
Name check:
Fix check:
Regression:

Description

installing rudder-agent on centos5 minimal fails due toi missing libpcre

here is an extract:

==> centos_agent1: CFEngine binaries copied to workdir
==> centos_agent1: /var/rudder/cfengine-community/bin/cf-agent: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory
==> centos_agent1: /var/tmp/rpm-tmp.78428: line 75: /var/rudder/share/man/man8/cf-agent.8.gz: No such file or directory
==> centos_agent1: /var/rudder/cfengine-community/bin/cf-promises: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory
==> centos_agent1: /var/tmp/rpm-tmp.78428: line 75: /var/rudder/share/man/man8/cf-promises.8.gz: No such file or directory
==> centos_agent1: /var/rudder/cfengine-community/bin/cf-key: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory
==> centos_agent1: /var/tmp/rpm-tmp.78428: line 75: /var/rudder/share/man/man8/cf-key.8.gz: No such file or directory
==> centos_agent1: /var/rudder/cfengine-community/bin/cf-execd: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory
...
==> centos_agent1: rudder-agent[5589]: [INFO] Launching CFEngine Community cf-serverd...
==> centos_agent1: /var/rudder/cfengine-community/bin/cf-serverd: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory
==> centos_agent1: rudder-agent[5709]: [ALERT] no PID file for cf-serverd after 30 seconds. Trying again...
==> centos_agent1: /var/rudder/cfengine-community/bin/cf-serverd: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory
==> centos_agent1: rudder-agent[5831]: [ALERT] no PID file for cf-serverd after 60 seconds. Trying again...

Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #4119: On mixed 32/64 bits RHEL/CentOS 5, dependencies of rudder-agent may not be installed RejectedActions
Actions #1

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 3.0.0 to 2.10.11

The main problem is that yum install rudder-agent it tries to install i386 and x61 package, but only install pcre x64:

Reinstalling:
 rudder-agent                            i386                              1398866025:3.0.1.rc1.git201502100145-1.EL.5                            Rudder_3.0-nightly                             21 M
 rudder-agent                            x86_64                            1398866025:3.0.1.rc1.git201502100145-1.EL.5                            Rudder_3.0-nightly                             22 M
Installing for dependencies:
 pcre                                    x86_64                            6.6-9.el5                                                              base                                          119 k
Transaction Summary

Then after i386 fails as pcre is not installed in i386

Actions #2

Updated by Dennis Cabooter over 9 years ago

There is a very simple workaround for that. I did the same already a long time ago. Just do:

yum install rudder-agent.x86_64

In that case you don't install the useless i386 package.

Actions #3

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.11 to 2.10.12
Actions #4

Updated by François ARMAND over 9 years ago

  • Subject changed from Install rudder-agent 3.0 on centos5 fails to Install rudder-agent on minimal centos5 fails
  • Reproduced set to No
Actions #5

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.12 to 2.10.13
Actions #6

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 2.10.13 to 2.10.14
Actions #7

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.14 to 2.10.15
Actions #8

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 2.10.15 to 2.10.16
Actions #9

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.16 to 2.10.17
Actions #10

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.17 to 2.10.18
Actions #11

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.10.18 to 2.10.19
Actions #12

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.19 to 2.10.20
Actions #13

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.10.20 to 277
Actions #14

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 277 to 2.11.18
Actions #15

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #16

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #17

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #18

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #19

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #20

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #21

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.24 to 308
Actions #22

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 308 to 3.1.14
Actions #23

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #24

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #25

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #26

Updated by Benoît PECCATTE over 7 years ago

  • Assignee deleted (Matthieu CERDA)
Actions #27

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #28

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #29

Updated by Jonathan CLARKE over 7 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
Actions #30

Updated by Benoît PECCATTE over 7 years ago

  • Priority set to 30
Actions #31

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
Actions #32

Updated by Benoît PECCATTE about 7 years ago

  • Is duplicate of Bug #4119: On mixed 32/64 bits RHEL/CentOS 5, dependencies of rudder-agent may not be installed added
Actions #33

Updated by Benoît PECCATTE about 7 years ago

  • Status changed from New to Rejected

This is the same bug as #4119

Actions

Also available in: Atom PDF