Project

General

Profile

Actions

Bug #6294

closed

Slapd uses 259888kB swap

Added by Dennis Cabooter over 9 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Performance and scalability
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Name check:
Fix check:
Regression:

Description

Slapd uses 259888kB since Rudder 3.0. The total amount of memory in my Rudder server is 4G.


Related issues 1 (0 open1 closed)

Related to Rudder - Bug #6287: Rudder memory usage for a small installation must hold in a 4G serverRejectedNicolas CHARLES2015-02-20Actions
Actions #1

Updated by François ARMAND over 9 years ago

It may be due to the optimisation in OpenLDAP we made. OpenLDAP has a multi-layered architecture, and we have cache at different level. We observed that given the usage profile of openLDAP in Rudder, all data can easily be put in the first layer cache (so, big speed upgrade). So perhaps what you see is Linux learning that deeper level of cache and data are never accessed, and puts them in swap.

Is it a problem to have that in swap ? In http://www.rudder-project.org/redmine/issues/6287#note-4, you seems to think that no i/o are consumed for it, do you see other problems ?

Actions #2

Updated by Dennis Cabooter over 9 years ago

I don't see any problems with it right now. I just wanted to bring this to your attention, because I can't determine the impact.

Actions #3

Updated by Vincent MEMBRÉ over 9 years ago

  • Target version changed from 3.0.2 to 3.0.3
Actions #4

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 3.0.3 to 3.0.4
Actions #5

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 3.0.4 to 3.0.5
Actions #6

Updated by Benoît PECCATTE about 9 years ago

  • Category set to Performance and scalability
Actions #7

Updated by Vincent MEMBRÉ about 9 years ago

  • Target version changed from 3.0.5 to 3.0.6
Actions #8

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 3.0.6 to 3.0.7
Actions #9

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 3.0.7 to 3.0.8
Actions #10

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 3.0.8 to 3.0.9
Actions #11

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 3.0.9 to 3.0.10
Actions #12

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 3.0.10 to 3.0.11
Actions #13

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 3.0.11 to 3.0.12
Actions #14

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 3.0.12 to 3.0.13
Actions #15

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 3.0.13 to 3.0.14
Actions #16

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 3.0.14 to 3.0.15
Actions #17

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 3.0.15 to 3.0.16
Actions #18

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 3.0.16 to 3.0.17
Actions #19

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 3.0.17 to 302
Actions #20

Updated by Alexis Mousset about 8 years ago

  • Target version changed from 302 to 3.1.12
Actions #21

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 3.1.12 to 3.1.13
Actions #22

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 3.1.13 to 3.1.14
Actions #23

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #24

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #25

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #26

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #27

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #28

Updated by Jonathan CLARKE about 7 years ago

  • Status changed from New to Rejected

This issue doesn't seem to have any negative impact, and Rudder >= 4.1 uses a completely different LDAP backend (LMDB). Therefore, I'm closing this bug - if anyone ever sees a negative impact because of this, please reopen this issue.

Actions

Also available in: Atom PDF