Project

General

Profile

Actions

Bug #6306

closed

Complete error logging for ncf

Added by Vincent MEMBRÉ over 7 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
1
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

Some errors are skipped and not logged in ncf.

We should always have them logged.

We also do not catch correctly execption and do not have correct message error in ncf api

Here the job should be to explore tools/ncf.py tool/ncf_rudder.py and api/ncf_api_flask/views.py to check error management

THe goal is only to log errors, keep loggin in the same file


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #6318: ncf api error should be properly interpretedRejectedActions
Actions #1

Updated by Benoît PECCATTE over 7 years ago

  • Status changed from New to Rejected

Duplicates #6318

Actions #2

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #3

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category set to Generic methods
Actions

Also available in: Atom PDF