Project

General

Profile

Actions

Bug #6382

closed

Random sprurious "Unknown" reports in the Web Interface

Added by Nicolas CHARLES about 6 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
3
Category:
Web - Compliance & node report
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

Sometimes, some nodes have unknown states in the web interface. They seem to work correctly, and to send the correct reports, but on the web interface they have duplicated reports (twice too much, or even 8 times too much), without appearing reason
We could not reproduce it, so we are only guessing about the causes:
- rsyslog issue
- database issue
- expected reports error
- scala issue

Does not occur in 2.10, but does in 2.11


Related issues

Related to Rudder - Bug #6421: Messages can be dropped on the node, resulting in Unknown reports on the Web InterfaceReleasedJonathan CLARKE2015-03-17Actions
Actions #1

Updated by Nicolas CHARLES about 6 years ago

  • Reproduced set to No

Ok, from what I understand this happened when the syslog configuration was invalid, and caused reports to be sent multiple time

Actions #2

Updated by François ARMAND about 6 years ago

  • Status changed from New to Discussion
  • Assignee set to Nicolas CHARLES
  • Priority changed from 1 to 3

Nico, could you complete that ticket:

- is there any other ticket related to that one ?
- did you validated the cause of the problem ?
- do you have a way to correct it ?
- have you any idea about how to detect it if happening again, and (yes, that's christmas for me :) a way to prevent it completlly ?

Actions #3

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.11.9 to 2.11.10
Actions #4

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.11.10 to 2.11.11
Actions #5

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 2.11.11 to 2.11.12
Actions #6

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 2.11.12 to 2.11.13
Actions #7

Updated by Nicolas CHARLES almost 6 years ago

the problem was actually http://www.rudder-project.org/redmine/issues/6421, but with the webapp that displayed a cartesian product of the expected reports and the reports received, has it didn't know which one belonged where

Actions #8

Updated by Nicolas CHARLES almost 6 years ago

  • Related to Bug #6421: Messages can be dropped on the node, resulting in Unknown reports on the Web Interface added
Actions #9

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 2.11.13 to 2.11.14
Actions #10

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.11.14 to 2.11.15
Actions #11

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.11.15 to 2.11.16
Actions #12

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.11.16 to 2.11.17
Actions #13

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.11.17 to 2.11.18
Actions #14

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #15

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #16

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #17

Updated by Jonathan CLARKE almost 5 years ago

  • Status changed from Discussion to Rejected

Nicolas CHARLES wrote:

the problem was actually http://www.rudder-project.org/redmine/issues/6421, but with the webapp that displayed a cartesian product of the expected reports and the reports received, has it didn't know which one belonged where

That bug has been fixed now, so I'm closing this one. Please re-open it if this occurs again.

Actions

Also available in: Atom PDF