Project

General

Profile

Actions

Bug #6420

closed

rudder-agent cannot be updated with zypper update rudder-agent on SLES11

Added by Nicolas CHARLES over 7 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Regression:

Description

Using the command zypper update rudder-agent on SLES11 doesn't update rudder-agent
however, zypper update does update the package.
Weird, isn't it ?

Actions #1

Updated by Nicolas CHARLES over 7 years ago

sles-11-sp1-64:~ # zypper list-updates
Loading repository data...
Reading installed packages...
S | Repository              | Name         | Current Version                     | Available Version                   | Arch  
--+-------------------------+--------------+-------------------------------------+-------------------------------------+-------
v | Rudder RPM Repositories | ncf          | 0.201411131129-1.SLES.11            | 1398866025:0.201503091311-1.SLES.11 | noarch
v | Rudder RPM Repositories | rudder-agent | 1398866025:2.11.4.release-1.SLES.11 | 1398866025:2.11.8.release-1.SLES.11 | x86_64

but

zypper update rudder-agent
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Nothing to do.

Actions #2

Updated by Nicolas CHARLES over 7 years ago

it is unlickely to be a key issue, as the log /var/log/zypper.log says

2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [zypp] RpmDb.cc(importPubkey):939 Comparing '474A19E8' to: , 'A1912208', 'B37B98A9', '0DFB3188', '1D061A62', '3D25D3D9', '6F07D355', '7E2E3B05', '9C800ACA', '21F6
567A', '307E3D54', '474A19E8'
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [zypp] RpmDb.cc(importPubkey):939 Key [9322C330474A19E8-4eea5279] [Rudder Project (release key) <security@rudder-project.org>] [7C1698177904212DD58CB4D19322C33047
4A19E8] is already in the rpm trusted keyring.
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [zypp] RpmDb.cc(exportTrustedKeysInZyppKeyRing):902 Trusted key 474a19e8-4eea5279 imported in zypp keyring.

It sees that there is something to update

2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [zypper++] update.cc(mark_updates):844 [package]rudder-agent: S_KeepInstalled (I 1) (A 2)U__s_(33)rudder-agent-1398866025:2.11.8.release-1.SLES.11.x86_64(Rudder) 
update: adding requirement rudder-agent > 1398866025:2.11.4.release-1.SLES.11
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [zypper++] update.cc(selectable_update_report):696 best:      U__s_(33)rudder-agent-1398866025:2.11.8.release-1.SLES.11.x86_64(Rudder)
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [zypper++] update.cc(selectable_update_report):704 installed: I__s_(650)rudder-agent-1398866025:2.11.4.release-1.SLES.11.x86_64(@System)
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [zypper++] update.cc(selectable_update_report):705 highest:   U__s_(33)rudder-agent-1398866025:2.11.8.release-1.SLES.11.x86_64(Rudder)
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [zypper++] update.cc(selectable_update_report):767 [package]rudder-agent: S_KeepInstalled (I 1) (A 2)U__s_(33)rudder-agent-1398866025:2.11.8.release-1.SLES.11.x86
_64(Rudder) update: adding requirement rudder-agent > 1398866025:2.11.4.release-1.SLES.11

solver however says

2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92 job: install providing rudder-agent > 1398866025:2.11.4.release-1.SLES.11
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92  - job Rule #5783:
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92     rudder-agent-1398866025:2.11.8.release-1.SLES.11.i586 [23] (w1)
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92     rudder-agent-thin-1398866025:2.11.8.release-1.SLES.11.i586 [29] (w2)
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92     rudder-agent-1398866025:2.11.8.release-1.SLES.11.x86_64 [33]
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92     rudder-agent-thin-1398866025:2.11.8.release-1.SLES.11.x86_64 [36]
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92     rudder-agent-1398866025:2.11.4.release-1.SLES.11.x86_64 [650]I
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92     next rules: 0 0
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92 job: install providing glibc
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92  - job Rule #5784:
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92     glibc-2.11.1-0.17.4.x86_64 [217]I (w1)
2015-03-17 15:48:26 <1> sles-11-sp1-64(29473) [satsolver] PoolImpl.cc(logSat):92     next rules: 0 0

Actions #3

Updated by Nicolas CHARLES over 7 years ago

This is not related to 2.11.8; I setted up 2.11.7 repos, and the result is the same

Actions #4

Updated by Nicolas CHARLES over 7 years ago

Ok, this is getting weird
yast install rudder-agent does update the rudder-agent

Actions #5

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.9 to 2.11.10
Actions #6

Updated by Nicolas CHARLES over 7 years ago

  • Status changed from New to Rejected

Ok, the problem here was that the SLES had no support, and zypper was not up to date
With a proper SLES with proper support, zypper update rudder-agent does work as expected

Actions

Also available in: Atom PDF