Project

General

Profile

Actions

Question #6520

closed

it should be possible to update ncf

Added by Thomas Koch over 7 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
N/A
Assignee:
Category:
Generic methods
Target version:
Regression:

Description

As a user of ncf I'm supposed to write my own promisses in subfolders of ncf (50_techniques and 60_services) or even edit a file that comes with ncf (service_mapping.cf). After I've done this, it's not easy to update ncf.

It would be preferable to have all of ncf in one subfolder that I don't need to touch at all as a user. Than on updates I can delete the folder and copy the new ncf version in its place.

If you have another better solution please add it to the documentation!

Actions #1

Updated by Vincent MEMBRÉ over 7 years ago

  • Tracker changed from User story to Question
  • Status changed from New to Discussion
  • Assignee set to Thomas Koch
  • Target version set to 0.x

Hi Thomas!

Sorry about the late answer

Are you using our packages? or do you make a git clone of ncf repository? you should be able to copy the new tree of ncf without problem.

If you are using our packages You should not use the directory /usr/share/ncf/tree to store your own techniques, because it will be overwritten by package update. you should have a copy of ncf directory elsewhere

Actions #2

Updated by Benoît PECCATTE almost 7 years ago

  • Status changed from Discussion to Resolved

No news since 7 months.
Feel free to reopen if needed.

Actions #3

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
Actions #4

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category set to Generic methods
Actions

Also available in: Atom PDF