Project

General

Profile

Bug #6525

On RedHat, upgrading from 2.11.8 to 2.11.10 fails, as the script rudder-upgrade fails to connect to the ldap directory

Added by Nicolas CHARLES about 5 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
1
Assignee:
-
Category:
Packaging
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:

Description

On a redhat system, upgrading fails as the script rudder-upgrade doesn't succedded: it tries 10 times to connect to ldap directory but fails with

can't contact LDAP server

the ldap service is correctly running (webapp is running fine), running manually the command fails directly
ldap is correctly listening on port 389

#1

Updated by Nicolas CHARLES about 5 years ago

  • Priority changed from N/A to 1
#2

Updated by Matthieu CERDA about 5 years ago

  • Status changed from New to Discussion
  • Assignee changed from Matthieu CERDA to Nicolas CHARLES

Hello nico,

"running manually the command fails directly" => You mean running the rudder-upgrade manually ?

It fails directly, without retrying a few times before ?

#3

Updated by Nicolas CHARLES about 5 years ago

  • Status changed from Discussion to New
  • Assignee changed from Nicolas CHARLES to Matthieu CERDA

Yes, running rudder-upgrade fails after 10 retries, and running manually the command used to connect to the ldap fails directly

#4

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 2.11.11 to 2.11.12
#5

Updated by Nicolas CHARLES almost 5 years ago

This problem still happens !

INFO: Setting rudder-slapd as a boot service... Done

INFO: Reloading syslogd...  Done

INFO: Stopping rudder-slapd... Done

INFO: Starting rudder-slapd... Done

INFO: OpenLDAP database was successfully upgraded to new format

INFO: Running the Rudder upgrade script to replay LDAP migrations on the old database content...

INFO: Checking if rudder-web.properties database access credentials are all right... LDAP OK,  SQL OK

INFO: Checking if inventory-web.properties database access credentials are all right... LDAP OK,  SQL skipped

INFO: Checking LDAP service status............ FAILED

LDAP service verification failed after 10 tries. Aborting the migration.

Please restart the LDAP service, and start the migration script again.

(on a single Rudder server, try service rudder-server-root restart)

Once it is working, run:

# /opt/rudder/bin/rudder-upgrade

INFO: You can safely remove the backups in /var/rudder/ldap/openldap-data-backup-upgrade-on-20150605115314/

INFO: and /var/rudder/ldap/backup/openldap-data-pre-upgrade-20150605115314.ldif

INFO: Restarting rudder-slapd... Done

  Updating   : 1398866025:rudder-inventory-endpoint-2.11.11.release-1.EL.6.noarch                                        6/18
#6

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.11.12 to 2.11.13
#7

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.11.13 to 2.11.14
#8

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.14 to 2.11.15
#9

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.15 to 2.11.16
#10

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.16 to 2.11.17
#11

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.17 to 2.11.18
#12

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.18 to 2.11.19
#13

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 2.11.19 to 2.11.20
#14

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.11.20 to 2.11.21
#15

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 2.11.21 to 2.11.22
#16

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.11.22 to 2.11.23
#17

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.11.23 to 2.11.24
#18

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 2.11.24 to 308
#19

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 308 to 3.1.14
#20

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.14 to 3.1.15
#21

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.15 to 3.1.16
#22

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.16 to 3.1.17
#23

Updated by Benoît PECCATTE over 3 years ago

  • Assignee deleted (Matthieu CERDA)
#24

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.17 to 3.1.18
#25

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 3.1.18 to 3.1.19
#26

Updated by Benoît PECCATTE about 3 years ago

  • Status changed from New to Rejected

2.11.10 is not supported anymore

Also available in: Atom PDF