Project

General

Profile

Actions

Bug #6621

closed

The file_ensure_line_present_in_ini_section bundle does not handle line editing

Added by Alexis Mousset over 7 years ago. Updated 4 months ago.

Status:
Released
Priority:
N/A
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

The file_ensure_line_present_in_ini_section bundle can add a given line (like "name=value") to a section, but will not edit a line with the same key existing in the section.

We could use the CFEngine stdlib wich provides a set_variable_values_ini bundle handling this.


Related issues 1 (0 open1 closed)

Has duplicate Rudder - Bug #7312: add generic method to manage key = value in INI sectionRejectedBenoît PECCATTEActions
Actions #1

Updated by Alexis Mousset over 7 years ago

  • Status changed from New to In progress
Actions #2

Updated by Alexis Mousset almost 7 years ago

  • Is duplicate of Bug #7312: add generic method to manage key = value in INI section added
Actions #3

Updated by Alexis Mousset almost 7 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Alexis Mousset to Nicolas CHARLES
  • Pull Request set to https://github.com/Normation/ncf/pull/258
Actions #4

Updated by Benoît PECCATTE almost 7 years ago

  • Status changed from Pending technical review to Pending release
Actions #5

Updated by Benoît PECCATTE almost 7 years ago

  • Status changed from Pending release to Rejected

Duplicates #6621

Actions #6

Updated by Benoît PECCATTE almost 7 years ago

  • Status changed from Rejected to Pending release
Actions #7

Updated by Benoît PECCATTE almost 7 years ago

  • Is duplicate of deleted (Bug #7312: add generic method to manage key = value in INI section)
Actions #8

Updated by Benoît PECCATTE almost 7 years ago

  • Has duplicate Bug #7312: add generic method to manage key = value in INI section added
Actions #9

Updated by Vincent MEMBRÉ about 6 years ago

  • Status changed from Pending release to Released
Actions #10

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #11

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category set to Generic methods
Actions

Also available in: Atom PDF