Project

General

Profile

Actions

User story #6719

closed

Suppress webapp logs after some time

Added by Nicolas CHARLES almost 9 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
N/A
Category:
Web - Maintenance
Target version:
UX impact:
Suggestion strength:
User visibility:
Effort required:
Name check:
Fix check:
Regression:

Description

The log of the webapp, in /var/log/rudder/webapp, are never purged, resulting in a growing disk usage, for no reason.

We should suppress them after 30 days, like the core logs - so modify the logback.xml file accordingly


Related issues 2 (1 open1 closed)

Related to Rudder - Bug #6381: File /var/log/rudder/{compliance/non-compliant-reports.log, core/rudder-webapp.log} are not correctly rotatedReleasedNicolas CHARLES2015-03-11Actions
Related to Rudder - User story #6384: Clean log rotation & compression letting Java aloneNew2015-03-11Actions
Actions #1

Updated by Nicolas CHARLES almost 9 years ago

  • Assignee changed from François ARMAND to Nicolas CHARLES

i'm taking over this ticket

Actions #2

Updated by Nicolas CHARLES almost 9 years ago

  • Target version changed from 2.10.15 to 2.11.12

rolling history appeared on 2.11

Actions #3

Updated by Nicolas CHARLES almost 9 years ago

  • Assignee changed from Nicolas CHARLES to François ARMAND

ok, i'm un-tacking over this ticket, it's not as trivial as I thought, and don't have to possibitily to work on it right now

Actions #4

Updated by François ARMAND almost 9 years ago

  • Related to Bug #6381: File /var/log/rudder/{compliance/non-compliant-reports.log, core/rudder-webapp.log} are not correctly rotated added
Actions #5

Updated by François ARMAND almost 9 years ago

  • Related to User story #6384: Clean log rotation & compression letting Java alone added
Actions #6

Updated by Nicolas CHARLES almost 9 years ago

ok, the org.eclipse.jetty.util.RolloverFileOutputStream in /opt/rudder/jetty7/etc/jetty-loging.xml defines 90 days of retention

Actions #7

Updated by François ARMAND almost 9 years ago

This part is managed by the logging from Jetty.
So it is configured in /opt/rudder/jetty7/etc/jetty-logging.xml file, for attribute: <Arg type="int">90</Arg> (very explicit, yes :)

Our current configuration states that log files are kept 90 days, and it is right that it may be too long.

Nicolas, as a workaround, you can already change the value in the config file. And we can change it in following release to a smaller value (30 days is good).

Actions #8

Updated by Vincent MEMBRÉ almost 9 years ago

  • Target version changed from 2.11.12 to 2.11.13
Actions #9

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.13 to 2.11.14
Actions #10

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.14 to 2.11.15
Actions #11

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.15 to 2.11.16
Actions #12

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.16 to 2.11.17
Actions #13

Updated by Vincent MEMBRÉ over 8 years ago

  • Target version changed from 2.11.17 to 2.11.18
Actions #14

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #15

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #16

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #17

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #18

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #19

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #20

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.24 to 308
Actions #21

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 308 to 3.1.14
Actions #22

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #23

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #24

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #25

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #26

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #27

Updated by Benoît PECCATTE about 7 years ago

  • Tracker changed from Bug to User story
  • Subject changed from webapp logs are never suppressed to Suppress webapp logs after some time
  • Status changed from New to Rejected

this is done since 2.11

Actions

Also available in: Atom PDF