Project

General

Profile

Actions

Bug #6995

closed

rudder-agent is stuck, waiting for user input during log compression

Added by Nicolas CHARLES over 8 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
1
Category:
System techniques
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Priority:
45
Name check:
Fix check:
Regression:

Description

Again, log compression is stuck:

R: @@server-roles@@result_repaired@@server-roles@@server-roles-directive@@115@@Check WebDAV credentials@@None@@2015-07-16 00:20:00+00:00##root@#The Rudder WebDAV user and password were updated

2015-07-16T00:20:59+0000    error: /default/root_component_check/methods/'any'/default/compress_webapp_log/files/'/var/log/rudder/webapp'[0]: Finished command related to promiser '/var/log/rudder/webapp' -- an error occurred, returned 2
2015-07-16T00:20:59+0000    error: /default/root_component_check/methods/'any'/default/compress_webapp_log/files/'/var/log/rudder/webapp'[0]: Transformer '/var/log/rudder/webapp/2015_06_18.stderrout.log' => '/bin/gzip "/var/log/rudder/webapp/2015_06_18.stderrout.log"' returned error

2015-07-16T00:21:00+0000    error: /default/root_component_check/methods/'any'/default/compress_webapp_log/files/'/var/log/rudder/webapp'[0]: Finished command related to promiser '/var/log/rudder/webapp' -- an error occurred, returned 2
2015-07-16T00:21:00+0000    error: /default/root_component_check/methods/'any'/default/compress_webapp_log/files/'/var/log/rudder/webapp'[0]: Transformer '/var/log/rudder/webapp/2015_05_18.stderrout.log' => '/bin/gzip "/var/log/rudder/webapp/2015_05_18.stderrout.log"' returned error
2015-07-16T00:21:00+0000    error: /default/root_component_check/methods/'any'[0]: Method 'compress_webapp_log' failed in some repairs

happens on 3.1, but may happens on 3.0 as well (or even 2.11)
Again, why do we compress the current .log file ??


Related issues 2 (0 open2 closed)

Related to Rudder - Bug #6439: rudder-agent is stuck, waiting for user input during log compressionReleasedNicolas CHARLES2015-03-26Actions
Is duplicate of Rudder - Bug #7985: gzip can stop rudder agent when compressing log filesReleasedNicolas CHARLES2016-02-26Actions
Actions #1

Updated by Nicolas CHARLES over 8 years ago

  • Related to Bug #6439: rudder-agent is stuck, waiting for user input during log compression added
Actions #2

Updated by Benoît PECCATTE almost 8 years ago

  • Target version set to 2.11.21
Actions #3

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #4

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #5

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #6

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.24 to 308
Actions #7

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 308 to 3.1.14
Actions #8

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #9

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #10

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #11

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #12

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #13

Updated by Jonathan CLARKE almost 7 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Getting started - demo | first install | level 1 Techniques
  • Priority set to 45
Actions #14

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
Actions #15

Updated by Jonathan CLARKE almost 7 years ago

  • Assignee deleted (Benoît PECCATTE)
Actions #16

Updated by Nicolas CHARLES almost 7 years ago

  • Assignee set to Nicolas CHARLES
Actions #17

Updated by Nicolas CHARLES almost 7 years ago

  • Is duplicate of Bug #7985: gzip can stop rudder agent when compressing log files added
Actions #18

Updated by Nicolas CHARLES almost 7 years ago

  • Status changed from New to Rejected

fixed by Bug #7985: gzip can stop rudder agent when compressing log files

Actions

Also available in: Atom PDF