Project

General

Profile

Actions

User story #6997

closed

The technique SSHKeyManagement doesn't allow to define several keys per user, and flush others

Added by Nicolas CHARLES almost 9 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Techniques
UX impact:
Suggestion strength:
User visibility:
Effort required:
Name check:
Fix check:
Regression:

Description

If I use sshKeyManagement, I canno't set several keys per user, and flush all others
If I set key1 for user root, with tag tag1, key2 for user root, and tag tag2, and key3 for user root, tag3, I can't enforce these 3 keys for root:
  1. if i set flush for each, this is always repaired, and I get only one key at the end
  2. if i set flush for only one, it is still always repaired, and I can have either one or two keys

We should group keys (and flush), per users


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - User story #12357: Port "SSH authorised keys" Technique to multiversionned techniqueReleasedNicolas CHARLESActions
Actions #1

Updated by Benoît PECCATTE about 8 years ago

  • Target version set to 2.11.21
Actions #2

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #3

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #4

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #5

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.24 to 308
Actions #6

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 308 to 3.1.14
Actions #7

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #8

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #9

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #10

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #11

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #12

Updated by Benoît PECCATTE over 7 years ago

  • Tracker changed from Bug to User story
Actions #13

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
Actions #14

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.20 to 3.1.21
Actions #15

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.21 to 3.1.22
Actions #16

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.22 to 3.1.23
Actions #17

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.23 to 3.1.24
Actions #18

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.24 to 3.1.25
Actions #19

Updated by Benoît PECCATTE over 6 years ago

  • Target version changed from 3.1.25 to 4.1.9
Actions #20

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.9 to 4.1.10
Actions #21

Updated by Benoît PECCATTE over 6 years ago

  • Target version changed from 4.1.10 to Ideas (not version specific)
Actions #22

Updated by Nicolas CHARLES about 5 years ago

  • Status changed from New to Rejected

done in #12357

Actions #23

Updated by Nicolas CHARLES about 5 years ago

  • Is duplicate of User story #12357: Port "SSH authorised keys" Technique to multiversionned technique added
Actions

Also available in: Atom PDF